Spark 2.6 beta - Proxy config nt working

I have downloaded the latest source **release 11044 **from svn. I compiled and ran the spark.

i have 2 proxys running, http (with username and password) and socks (without username/password, running based on ip restriction). spark 2.5.8 at present connects on both http and socks but the current compiled version 11044 of spark beta2 doesnot connect via proxy. I even tried reverting back to 11036, it also doesnot connect via proxy.

Please note i have the proxy working fine with version 2.5.8 perfect now. Also the version i compiled is untouched as fresh from the source.

while i am running the spark from source itself, there is a java window (hope you all got this)

Now in this a error is thrown when i am clicking advanced button in login window

Debug is true storeKey false useTicketCache true useKeyTab false doNotPrompt tr
ue ticketCache is null isInitiator true KeyTab is null refreshKrb5Config is fals
e principal is null tryFirstPass is false useFirstPass is false storePass is fal
se clearPass is false
Acquire TGT from Cache
Error calling function Protocol status: 1312
A specified logon session does not exist. It may already have been terminated.
Principal is null
null credentials from Ticket Cache
[Krb5LoginModule] authentication failed
Unable to obtain Princpal Name for authentication

Anybody please help ??? No developers responding since so looong ?

Spark currently has only one developer and he is not working at Jive, only a community member doing this in his spare time. Currently he has some other priorities, so probably this will not be addressed fast enough. Personally i have only tried anonymous public http proxy and it worked fine. I dont have logins to any authorised http or socks proxies.

Even http anonymous not working for me. Please contact me on google talk id: ashokjp

We can check

You should get my invite in Gtalk. Where do you live? Wonder when we are able to find each other online I’m on GMT +02:00 (Lithuania, East Europe).

I have set your clock in my pc, so would know your time, i wil be online for sometime now. or tell me a time we can check up

I was testing today with 11071 svn version and it seems Spark is not obeying proxy settings. I can put any IP and port and eventually Spark will connect. I think maybe it tries to connect via proxy and if fails, then it just connects directly. Maybe i should file this as a bug.

Environment: I am using Squid as my proxy server in between Internet and my place. I added 5222 and 5223 to trusted SSL port to squid.conf and restarted squid service.

Test Criteria:

  1. Connected to XMPP network and can send to msg to XMPP network back-n-forth.

  2. In my environment doesn’t work, it keeps reporting missing tag.


I think someone should have rewritten the ConnectionConfiguration related code in but I didn’t dig into SVN history. There is nologic to check and read proxy settings when starting smack. The proxy settings were used when checking plugins availability and upgrade info, though.


Fixed (at least partially).

Modified file(s):

SVN Revision: 12897 (latest) (832 Bytes)

Attached your patch to the ticket SPARK-1066

can somebody please send me updated jar file.

This update hasn’t been applied and the patch isn’t applying to the current Spark source code, so there is no updated jar.

Thank wroot for update. Can you please point me to correct source code link. I will try to apply patch for my use and see if it helps.

Thank you.

The source is available via Git

Thanks. I played around with it and it seems like there are many changes committed in class. After my changes I am getting java.lang.NoSuchMethodError: Could you please point me to 2.6.3 Spark code. Thank you so much

It may be in the same repository somewhere. I know that versions are some how tagged to be able to get back to a particular version, but i can’t help with that, not a programmer myself.

Can anyone using a working proxy for xmpp try it with this build and report is it working?