powered by Jive Software

Spark 2.8.0 login problem with server name as IP

wroot escreveu:

Nuno, are you putting IP address 192.168.1.165 in the Server field of your Spark? What is the name of your Openfire server? You can check it when logged into Admin Console (Server Name). You should put Server Name value instead of IP into Server field. Then go to Advanced menu on the Login screen and uncheck Automatically discover host and port, then put 192.168.1.165 into host field and press OK. Then try logging in.

First,

I already try putting, on the Connection box (inside advanced connections preferences), my ip (as 192.x.x.x) and also like my dns (as mydomain.com) and nothing has worked so far.

My server name in Admin Console (Server Name) is ‘192.168.1.165’.

By the way, I never have “Automatically discover host and port” checked.

I have branched out your issue into a separate thread (to make it more convenient to track).

Well, maybe certificates doesn’t work when IP address is used as a name. What happens if you actually make that checkbox checked?

You can try the testing build of 2.8.0 which have an option (in the Advanced menu on the Login screen) to Disable certificate hostname verification: http://download.igniterealtime.org/spark/dailybuilds/spark_2_8_0_886.exe

Keep in mind, that this will make your client vulnerable to certificate spoofing attack. But you might not care about it in a closed safe environment.

Ok, I just got 2.8.0 running ok inside my lan.

On server side, changed xmpp.domain to cname domain. On client side, on Spark 2.8 changed server to cname domain but most important, on Advanced connection preferences I checked “Automatically discover host and port”. Also User compression and Accept all certificates are both checked.

Now I can login fine. On older 2.7.7 also can login.

The problem now is connecting via WAN.

I’m using two apps. Normal Spark, 2.8 and 2.7.7, and Xabber for Android.

With 2.7.7 and Xabber I can login fine, for now. With Openfire 4.1 all is going to change.

With 2.8 I can’t. No matter what I do, I simply can’t login. Maybe cause Server for WAN (I’m using a ddns domain to point to my real server ip) differs from the one used over lan.

Is there a solution for this? I think that should be more flexibility for this aspect. We should be logged in no matter we are over lan or wan.

For now I can maintain 2.7.7 on my clients that need to connect over WAN but when Openfire 4.1 is going to be released all is going to change.

You can try 2.8.0 886 from the link above and enable “Disable certificate hostname verification” setting. This is a not recommended workaround, but should work, if you can’t figure out another way.

So, when you connect from WAN, what do you put as a Server in Spark? If that doesn’t match what you put from LAN, then it must be a domain mismatch in the certificate. You can try putting the same value as with LAN, but then put your ddns host in the Advanced menu, by unchecking “Automatically discover host and port”.

1 Like

Ok, I think I got it. On main login windows I have the server name that is the same that is inside openfire server.

Inside Advanced menu, I have the ddns name and respective port. Unchecked Automatically discover host and port and even with Disable Certificate uncheched I now can login on my WAN Spark 2.8.0 users!!!

Bingo You now have the correct setup.

1 Like