powered by Jive Software

Spark 2.8.2 (Build 943) doesn't save profile information

After I enter anything, click “Save” and go back to “Edit my profile…” it is blank again.

Is it a bug or is there a solution to this problem?

Works fine for me. What is your setup? Openfire version, LDAP in use or not? Database?

Any logs in C:\Users\User\AppData\Roaming\Spark\logs ?

Openfire 4.0.2

No LDAP

Local database?

Nothing interesting in logs

The information gets saved when using older Spark versions though.

Can you determine in which version it breaks? You can try some older builds which are still on the nightly builds page.

Hi,

i have the same issue. Any changes in user profile aren’t saved. In older version of Spark (i.e. 2.7.7) that works fine.

Actually installed Openfire v.4.0.3, but that problem exists also in v.4.1.3.

DB: MS SQL Server 208R2

Can anyone help?

As i can’t reproduce it, it is really hard to suggest anything. You can zip all the logs found at C:\Users\User\AppData\Roaming\Spark\logs\ and attach them here (use the advanced editor in the corner). Try editing and saving the profile a few times before that. Also, no LDAP integration?

How about trying out latest 2.9.0 nightly builds? Ignite Realtime: Spark Nightly Builds

Logs in attach.

There’s no LDAP integration, and yes, the newest version of Spark (2.9.0) has the same problem.
logs.zip (4683 Bytes)

Well, i see no hints in these logs. Let’s try debugger. On the login screen in Spark go to Advanced and enable the debugger (last option). When you login it will open a separate window. Press on the first tab, go to Raw Sent Packets, right click and clear, go to Raw Received and clear also. Then try changing your profile and hit Save. Go to both tabs and copy (with right click) the text, save in a txt file and attach here.

Attached.
raw.zip (1077 Bytes)

That’s strange. Your logs are missing actually getting and sending updated vCard information. This is how it looks on my side:

Raw Sent:

Tester <PAGER/ >uihkjh</LO CALITY></vCa rd>

First it’s get (when i press Edit my profile) and then set, when i press Save. When it is getting vCard the server responds:

Raw Received:

</ ORG>Tester3 <WORK/ ><HOME/ >uihkjh

Don’t know why in your case it is missing and why this issue started with 2.8.

Maybe, there’s something with option ‘Accept all certificates’, which has been added in Spark 2.8?. I have self signed certificates.

No. I have self-signed certificates and i have this option enabled.

I’ve found source of that problem. It’s Client Control plugin in Openfire. When option “Avatars - (Spark Only) ** Allow users access to the “Avatar” tab.” is Disabled, Spark users cannot change theirs profiles. That’s Bug, can anyone fix it please?

I have filed [SPARK-2009] Should allow profile changes when Avatar tab is disabled - IgniteRealtime JIRA Not sure when and who will fix it.

1 Like

Thank You

This issue has been fixed with the recent patch (https://github.com/igniterealtime/Spark/pull/396) by Alexander. Should be included in 2.9.0.