powered by Jive Software

Spark 2.8 login problem - server.mydomain.com or chat.mydomain.com

Can you give a bit more detail? I have server.mydomain.com running Openfire and *chat.mydomain.com *(a CNAME) in the server box. The Openfire server properties (via the admin interface) say its name is just server.

What would be whatever you use for your xmpp domain in this case and what would go in the advanced host box? Can’t seem to find the right combination

Thanks

I have branched out your issue into a separate thread to make it easier to track.

have you tried putting server into Server field and server.mydomain.com in the Advanced menu? Also check in Admin Console - TLS/SSL certificates - Manage Identity Store. For what name are your certificates generated? Is it server?

server, server.mydomain.com unfortunately does not work.

Also tried: IP/IP, server/IP, server.mydomain.com/IP, chat/IP, chat.mydomain.com/IP, IP/server, IP/server.mydomain.com, IP/chat, IP/chat.mydomain.com

I have self signed certificates for both *.server and *.chat in the identity store.

Can’t see anything that looks related in the logs, where would it be?

Well, this looks like a complex issue in your case. And it would be hard for me to recreate such scenario. So i think you should stay with 2.7.7 for now and wait for 2.8.1 which will probably have an option to ignore hostname mismatch between server and certificates.

Thanks, if I do figure out a solution I’ll log it here.

You can try the testing build of 2.8.0 which have an option (in the Advanced menu on the Login screen) to Disable certificate hostname verification: http://download.igniterealtime.org/spark/dailybuilds/spark_2_8_0_886.exe

Keep in mind, that this will make your client vulnerable to certificate spoofing attack. But you might not care about it in a closed safe environment.