powered by Jive Software

Spark 2.8 Openfire 4.0.3 Can't log in

When upgrading Spark to 2.8, it fails to login. It appears to be an issue with server configuration. In my current setup (running on Ubuntu), the server name is the default showing up as “core”. When our clients connect, we have a dns record that simply points to the server for chat.localdomain. Do I need to modify the server name for spark 2.8 to work and if so, how can I do that without breaking the server configuration? If I need to create a SRV record instead, what is an example of the proper record to be created (using Microsoft DNS service)? Please advise. Thank you.

BTW, the users show up in Spark & Openfire as user@core

I think srv records might not work here. Can’t help with exact instructions but you can check this example Check DNS SRV records for XMPP

You can try to change the name of your server by rerunning the setup (by changing the last tag in openfire.xml to the opposite value - setup). As this is an already in production server, do a backup first. Your usernames will change to @chat.domain so if someone had manually added contacts to their roster, they would stop working probably.

You can also use 2.8.1 and check Disable hostname certificate verification in Advanced menu on Spark’s login screen.

Also, after changing server’s name go to certificates store in admin console and delete old certificates for ‘core’.

The option to disable hostname certificate verification did not work. Ideally, if I can make spare 2.8 behave like 2.7, that would save me trying to reconfigure the server and then users losing their contacts they have added.

What error do you get after enabling that option? Btw, Accept all certificates has to be enabled too, but it should be checked by default.

It fails to login.

I mean what error EXACTLY, because that is important.

The exact error is “Invalid username or password”

Well, that’s not the error which should be showing in case of bad hostname and certificate mismatch. Were you getting the same error before enabling “Disable hostname certificate verification”? In that case this is some other issue, maybe network related. What errors do you get in the logs? C/users/user/appdata/roaming/spark/logs

I get the same error message when selecting “Disable hostname certificate verification” as well. I don’t see how this can be network related since it works fine with 2.7 so clearly how 2.8 connects has changed.

This is what I see in the error logs;

SEVERE: connection error

org.jivesoftware.smack.SmackException$NoResponseException: No response received within reply timeout. Timeout was 10000ms (~10s). Used filter: No filter used or filter was ‘null’.

I understand that. I just meant that this doesn’t seem to be certificate related. This error seems familiar, discussed in Spark Disconnects thread (no solution yet). What happens if you retype your password and try to login or close that error and try to login again?

Forgot to mention that I also tried to enter the IP of Open fire under domain and under host and port. Both provide the same error message.

I treid that as well. We are not using self-signed certs so I don’t think it’s a certificate issue anyway since it behaves properly on 2.7. Odd.

Is your login (and password) using only latin (english) characters?

Using AD password so it’s complex (numbers, charaters, etc…)

What about username? So, it’s AD integrated, that might be related also. Are you using SSO?

User name is only letters. SSO is disabled.