powered by Jive Software

Spark 2.8 Problem Logging In

When installing version 2.8.0 of Spark we are seeing a problem where users cannot login to an OpenFire 3.7 server.

When Spark version 2.8.0 is uninstalled and Spark version 2.7 (spark_2_7_0_665.exe) is installed login works Ok.

This version of Spark 2.7 was chosen for no other reason than it was the latest version that we had available that we already had downloaded.

It looks like there have been other releases of 2.7.x before 2.8.0. Are the versions between 2.7 and 2.8 still available to download from somewhere that will allow us to confirm in which version this login problem appears?

Do you have some pointers how this can be debugged?

Having the same issue here, Have updated openfire to 4.0.3 but still no luck.

Tells me that my username and password at invalid… but I can use them to log into the openfire admin interface!

There is an announcement above the forums related to login issues. You can download any version by replacing version numbers in the download link url. This issue appeared in 2.8.0 and the last version not affected by this was 2.7.7.

Thanks for the pointer and explaination.

As a last question is there anything to be aware of when upgrading Openfire server from 3.7 to 4.0.3?

That’s a rather huge gap between versions, so anything can happen I think i would consult changelog to see what version numbers was in releases and would download and install updates (you can download older versions of Openfire same as with Spark) in small increments (like 3.8.2, then 3.9.4 and so on), rather than going straight to 4.0.3. In theory it should work and upgrade database to 4.0.3 version, but in practice sometimes upgrade scripts fail for one or another reason.