powered by Jive Software

Spark 2.9.3 Exception in Login error

Hello,

I’m using openfire version 4.5.3 and it’s working fine.
I got just one workstation with an issue that I coudn’t fix.

This workstation is windows 10 pro and it’s up to date. I’ve set up an inbound firewall rule from my openfire ip server on 5223 and 5223 port (managed by bitdefender solution) and windows firewall is disable.
When I try to login in using any user from this workstation I got this log error below.

out 27, 2020 10:21:10 AM org.jivesoftware.spark.util.log.Log error
GRAVE: Exception in Login:
org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: 'eqxsrvapl003:5222' failed because: eqxsrvapl003/10.180.108.173 exception: java.net.ConnectException: Connection timed out: connect
	at org.jivesoftware.smack.SmackException$ConnectionException.from(SmackException.java:292)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectUsingConfiguration(XMPPTCPConnection.java:668)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectInternal(XMPPTCPConnection.java:971)
	at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:435)
	at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1102)
	at org.jivesoftware.LoginDialog$LoginPanel.access$900(LoginDialog.java:365)
	at org.jivesoftware.LoginDialog$LoginPanel$3.construct(LoginDialog.java:904)
	at org.jivesoftware.spark.util.SwingWorker.lambda$new$1(SwingWorker.java:139)
	at java.lang.Thread.run(Unknown Source)

I have plent of client connected from the same network, anyone could help me? Any ideia wold be great.

Best Regards

Does this perhaps mean that you accidentally added the port number to the domain name somewhere?

I did not.
On spark in advanced options > general this port value is there by default.
I can ping and solve my server name with no problem.
I’ve tried using FQDN server and also IP insted, however, the erros is always the same.

Do you mean you have setup such rule on this Windows 10 which is failing to login? First, 5222 is the port which is used commonly. Also, you don’t usually have to setup inbound rules to the client. Because this is TCP, client initiates connection to the server and then connection is maintained. Server never initiates connection to the client. And when server responds to the client in the TCP connection random high ports are used, not 5222 or 5223.

Hello,
Yes, i setup this firewall rule for my workstation that failing to login, thanks for explain me. It was just a guess,

I’ve tried others diferent versions of spark, cleaned all spark’s registers, deleted the folder on appdata, but still not able to login.

Are you putting “eqxsrvapl003” as domain in Spark’s login window? Do you put the same on other computers on the same network that are able to login? Maybe you can try to disable Bitdefnder for a bit to see if it is able to connect then.

Yes,
i’m using eqxsrvapl003 as domain for my all workstations and I also tried using it’s FQDN an IP.
I also did try disable the bitdefender for a while, but still not able to login.

In my network all workstation has bitdefender installed and with the same policy, just one machine is given me literaly a headache.

Can you ping eqxsrvapl003 from this machine? Also try nslookup eqxsrvapl003 on this machine. And also telnet eqxsrvapl003 5222

If it works on other machines with the same settings and on the same network, then it seems that something is wrong with network setup of this machine. It gives you a timeout error. Spark is not able to get a response. It could be that machine is actually trying to reach the wrong host. Also, it might be worth checking firewall on the server and maybe disabling it for a bit.