Spark 3.0.2 Error Login

I can login with 2.7.6 but with 3.0.2 it gives the following error

org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
	at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(
	at org.jivesoftware.smack.AbstractXMPPConnection.lambda$new$2(
	at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.accept(
	at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.access$200(
	at org.jivesoftware.smack.NonzaCallback.onNonzaReceived(
	at org.jivesoftware.smack.AbstractXMPPConnection.parseAndProcessNonza(
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1700(
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$
	at Source)

What version of Openfire are you using?

4.7.4, windows server 2019. workgroup

I wonder if 2.7.6 supported the SCRAM-SHA-1 authentication method. If that is not the case, then maybe this new method is now used for the first time, somehow creating a problem.

You can try to reset the password of the user that is having trouble logging in. This might correct the SCRAM-SHA-1 artifacts on the server.

Another approach is to disable SCRAM-SHA-1 support in Openfire. The downside of this is that you are disabling what is likely the strongest form of authentication in your server. You can configure the supported authentication mechanisms in Openfire’s admin console, under Server > Server Settings > Registration & Login

Another reason why this could occur is if you accidentally are trying to log into the wrong server. Even if your ‘domain’ is set correctly, Spark allows the ‘connect host’ to be manually supplied, instead of auto-detected. This is done in the ‘advanced settings’ menu. If that has been done, and you switch to another user on another account, Spark might be trying to connect to a server that doesn’t belong to the domain that was provided by the end-user.

It is a simple mistake, but would be very confusing. Ask me how I know. :slight_smile:

I tried with server name and ip, it didn’t work

SASL Mechanisms: I removed the SCRAM-SHA-1 check from
It gave an md5 error this time, I removed it, it gave a digest md5 error, I removed it and it gave the error of all of them again

I reset the passwords but it doesn’t work, I can’t login with the 3 versions.

Are you certain that Spark is talking to the server that you think it is talking to? Can you detect the network traffic from Spark on the Openfire server?