Spark 3.0.2 not connecting

Getting “can’t connect to server: invalid name or server not reachable”

Logs show “failed because connectexception: connection refused”

In the past when this happened we just reinstalled Spark and it worked, but this time its not working. Any ideas?


On first sight, this looks like an ordinary networking issue. Something is preventing Spark from making a connection to Openfire. This error does not tell us what the cause is.

Thanks for your quick response Guus!

All workstations can ping the server pwcdc3 and DNS is working fine, but all of our workstations are having this connection problem to Spark.

I connected to pwcdc3 and looked at listening ports, and did not see anything listening on 5222, which is the port mentioned in the error message. So I’m thinking rebooting the server is a good first step? Do you think that’s likely to fix the issue?


Guus, after what you had mentioned, I went on the server and started the openfire service. Then tried opening the openfire server app but got the error seen below.

I had a user try connecting to spark and same “can’t connect to server” error.

I think the error is telling you that your Openfire is not able to connect to your database. Maybe because of that Openfire is not even initializing at all. maybe check the database logs?

1 Like

I agree, this seems to be some kind of connection error between Openfire and the database that it is using. I think that this error is specific to SQLServer (but I’m not sure). I’ve never seen this one before though. Hopefully, your logs contain more information.

This is a common error is openfire is already running as a service, and you try to use the “launcher”.

Stop openfire service and exit the launcher
check for a database lock file. if you have one, delete it.
start openfire service
if still unable to connect, check the openfire log files in side the openfire folder