powered by Jive Software

Spark and XEP-0106: JID Escaping

Hello all,

I am about to (hopefully) migrate my organization from Jitsi over to Spark mainly for SSO (which I have working beautifully thanks to the docs here).

I have one problem user though who has a special character in his user name, an '. In reading XEP-0106: JID Escaping, I used \27 which I found here https://xmpp.org/extensions/xep-0106.html#escaping when creating the username in Jitsi, and I was able to login and everything works. As I suspected, SSO doesn’t work for this user because I assume Spark is not escaping the character. I tried to do it manually, but this also does not seem to work.

So my question is, does Spark support this/should it work, or am I up the creek? It does work in Jitsi.

I suppose you have already tested this with 2.8.0 version?

Yes, tried in both 2.8.0 and 2.7.7 (due to the login problems I’m having with 2.8.0).

Ok, going to file this as https://issues.igniterealtime.org/browse/SPARK-1803

Just an update, it looks like Spark natively handles this without the need to use the escaped characters. I tried again with 2.7.7 on a completely fresh install (deleted all traces of previous Spark 2.8.0 installation) and used the username without the \27 in the username and Spark logged in.

I see. So this is not about escaping special symbols, but some bigger problem with non unicode username. Modified the ticket.

As commented on the ticket, this has been fixed on the server’s side today (for the future 4.1.0 version). Closing Spark’s ticket.