powered by Jive Software

Spark Caindo a Conexão

Bom dia, Pessoal

Tenho um servidor openfire instalado no debian 6, e estou utilizando o cliente spark para as unidades conversarem entre si, só que o problema que está acontecendo é que fica só caindo o spark em uma determinada rede entrando e saindo direto. Também testei com outro cliente xmmp ( pidgin ) a conexão também cair.

O que poderia está ocasionando isso ?

carlosandre,

Muitas coisas podem causar essa queda de conexão. Verificou problemas na rede pingando o servidor por um bom tempo? Ou o serviço do Openfire pode estar reiniciando, portanto verifique os logs. O Openfire está na última versão? Eu estou instalando Openfire 3.8.2 e Spark 2.5.8 com SIP Asterisk, e como ainda estou testando não sei lhe dizer muito, mas as conexões são estáveis.

Bom dia, Rafael

Estou utilizando a versão 3.7.1, o servidor está normal não cair em nenhum momento, conforme informei isso só acontece nessa rede, tenho instalador em outras redes acessando meu servidor via nat e funcionando normal. somente nessa rede está acontecendo essa instabilidade.

Caso eu queira atualizar não vou peder nenhum informação, tem algum procedimento padrão ?

Carlos,

Depende do SO em que está instalado. Tenho o Openfeire instalado no FreeBSD 8.3 instalado pelo ports. Para atualizar apenas refiz a instalação. Não perdi nada, mas meus usuários são cadastrados no AD.

Segue dois links do fórum com informações importantes:

Abraços.

Olá,

Estou enfrentando o mesmo problema, diversas vezes ao dia, para todas estações simultaneamente.

Possuo o Spark 2.6.3 e OpenFire 3.7.1, ambos em um servidor Windows Server 2008 R2 Standard SP1 (64 bits).

Ping interno está 100% e não encontrei eventos que aparentam ser significativos.

Alguma sugestão?

Devo atualizar?

Obrigado.

Eládio Garcia

Estou com o mesmo problemas estou tentando achar alguma solução mais ainda nada, rodava o openfire no server 2003 sem problemas quando migramos para o 2008 r2 enfrento este problema, os usuarios simultaneamente ficam caindo!

Já atualizei o OpenFire para 3.8.2 e o problema persiste.

Algumas observações importantes principalmente para 2008 Server.

1 - É extremamente indicado que o serviço do Openfire rode com usuário administrador

2 - Certifique-se sobre as configurações do firewall para portas usadas pelo seu spark.

3 - Verifique se as quedas acontecem sempre no mesmo horário, pois pode haver alguma atividade agendade para este horário que esteja consumindo os recursos do seu servidor ou varrendo portas ou mesmo dando refresh nos serviços. Isso é muito comum com programas de autoverificação e diagnóstico em servidores, nós temos algumas ferramentas que, se não configuradas corretamente, podem restartar serviços do SO do servidor onde estão rodando diagnóstico.

4 - Quanto tempo o spark fica off? Ou é mesmo só uma queda e reconexão imediata? Se houver tempo de parada hábil, rode um portscan por um longo tempo e veja se há algum fechamento de porta na rede com problema.

Postem os resultados dos testes para enriquecer o fórum.

O Spark conecta e na mesma hora desconecta e fica reiniciando a conexão, entra e sai, passa 5 segundos logado e cai, identifiquei que quando coloco o IP estatico privado ou publico para conexão ele da esse problema, quando coloco o nome do dominio em servidor o spark segura e a conexão não cai, isso em todas as máquinas da rede, clientes externos conectam pelo IP publico sem problemas, o ping respondendo a todo vapor para o servidor, estou rodando a ultima versão do openfire 3.8.2 integrada ao AD, o serviço esta rodando com as credenciais de administrador. Observei que tinha outro usuario aqui do forum com o mesmo problema que o meu rodando também openfire em 2008 server r2.

Obrigado pela Atenção…

Olá Tiago, faz o seguinte. Configura qualquer programa pra usar a mesma porta configurada para o spark, daí vê se o programa funciona bem e sem interrupção, isso possibilitaria testar problemas com firewall e rotas. Mas provavelmente há alguma relação com o AD. E outra coisa, seu DNS está no AD?