powered by Jive Software

Spark - can't see other online users & Unable to add contacts

Hello,

Just installed Openfire 4_1_4 & Spark 2_8_3 following @wroot 's guide (very helpful); however, having set up some users in the server, installed spark on local machines, and signed users in successfully, I can’t seemingly add/see contacts (or send them messages). On one of the user logins I can see some of the other users that I’ve added to a group, but these all show as offline (one is, one isn’t). Have I set something up incorrectly/ missed a tick box somewhere?

On one of the user logins I can see some of the other users as offline but only after I’d added users to a group. These all show as offline though - one is, one isn’t.

I can send an admin broadcast from the server to all online users, and each receives this message. I can also see the online users in the client sessions page on the server, so there is some visibility, I just can’t see where I’ve gone wrong. Have I set something up incorrectly/ missed a tick box somewhere?

Can anyone assist?

Many thanks

Do you use the same domain name to login in Spark as it is set for your server? Or do you use IP in the Advanced settings? Are you able to search for users using Search field at the bottom of the roster window in Spark?

Hi, thanks. I have set the same domain name (“cochat”) and steered clear of IP addresses as per advice in the article.

One additional thing to note is that I only get a blank page on http://127.0.0.1:9090/index.html and have to use http://localhost:9090 - don’t know if that’s significant.

Yes, I can search from the bottom of the roster page. If I type in the other user name I get the right result, but on opening this (into the chat box/messenger) I can’t then add contact via the green ‘+’ icon - I just get an error message saying “Unable to add contact”. On trying to add the contact I’ve tried leaving the username at its default selected username Emma Hill@[].[].local, and also just the username Emma Hill.

Images below ni case they assist.

Thanks, Matt

Spark - Sign in.PNGOpenfire Server settings.PNG

Spark Search.png

I see that you search service is not just “search.cochat” but has different address. it should be search.cochat. Also i see in the last screenshot that your user’s JID contants some file, although it also should be user@cochat. Something is wrong here, but it is hard to understand what exactly. Also, do you usernames are with spaces? Try avoiding them. Although they should be escaped automatically, but it is a good practice not to use them in the usernames/JIDs.

Hi, thanks for coming back.

Yes, at present usernames had been spaced - I can amend/delete these and start again on them.

The different address in the search, and JID ‘file’ are both the same FQDN - servername.company.local - I thought I’d entered as per the below from the guide, perhaps I have entered these incorrectly?

  • Server’s name: aruba; server’s full name (FQDN): aruba.tempico.local
  • Chat server’s domain should be:corpchat.

Can I check or edit the server side or would it need re-installing?

Could the error be in the DNS settings here?

Openfire Properties.PNG

In your first screenshot i see that FQDN is cochat. If you server is servername, it should be servername instead. Maybe you can change this in the system properties, but if this is a fresh installation, i would reinstall to avoid problems in future.

In my example server’s name is aruba. And in Windows AD network when PC is joined into domain, it appends its domain name automatically. Usually internal domain has local in the name, so in this case tempico.local. But your server doesn’t have to have local in it’s name.

Have you put cochat or fileserver.ashfield.local as FQDN during the setup?

Thanks. I’ve uninstalled Openfire server but am going to need to wait until I can reboot the server to re-install out of hours. Will re-visit next week

I’m afraid this might not help. As we don’t need search and manually adding contacts i have never tried it on my production server (actually i had search disabled to not confuse people). I’m currently unable to search for users or add contacts on my production server. Although i was able in the past. Not sure what is the problem (it works fine on my test server, but it is not in Windows domain network).

I have filed a ticket to look into it, but i’m not a developer and not sure if i will be able to investigate this [SPARK-1943] Can’t access search service in some scenarios - IgniteRealtime JIRA

Btw, you don’t have to reboot your server to install or uninstall Openfire.

hmm…this works as expected for me. I’m using the full fqhn for my xmpp domain instead of the short name, and I have SRV records for my domain.

Are you wanting to federate with outside servers, have external access, or will this be strictly internal? if strictly internal, than that really simplifies things.

Having full fqdn of a server as xmpp domain goes against the general idea, that you might have xmpp domain APPLE and host it on a server PEAR.something.tld

My production server actually has the same name as i just named the server the same to distinguish it easier and my domain was “jiveserver”, which fitted the name for the server. Maybe that causes the trouble (similar names). Or maybe that’s some weird Spark issue. My server also has been migrated from Linux at some point, so there is that as well. I’m not 100% positive, but i think i have tried to use search at some point and it worked. Also, recently i have changed the IP of my server (after migrating its VM to another host) and changed the A host record accordingly. Shared groups, messaging and file transfer work ok, so i’m not sure why search isn’t. But i was testing from the same VM (as i’m out of office currently and can’t test locally on some PC, only remotely). Will check again on Monday probably.

sorry, for clarification my xmpp domain is APPLE.com vs the shortname of APPLE

i then have a srv record that points to xmpp.apple.com

and then an A record for xmpp.apple.com that points the the ip of the server.

The server name is server.domain.local

That seems superfluous… Why can’t srv record point directly to server.domain.local (which is in DNS also)? Same as A record for apple.com pointing to server’s IP. Of course if apple.com is not replicating some real domain. In my case xmpp domain is just a fake “jiveserver” domain, so there is no collisions.

This is still very confusing. Maybe i should try creating a srv record in my DNS. But when i thought about it in the past it seemed that i would just create a record pointing jiveserver to jiveserver.domail.local, which is essentially the same thing as domain.local is automatically attached. So i decided not to do anything, especially when the stuff i needed worked fine.

I really need to do a better job of being more complete!

mainly because apple.com would represent my external domain, and my SRV records and A record are set on my external dns. I then have an internal A record (split dns) for xmpp.apples.com so internal clients can connect directly (instead of having to worry about nat and hairpinning).

for internal only, I agree…I think everything should work as you described.