powered by Jive Software

Spark client 2.9.3 not showing message content

Hello,
I’m using Openfire 4.6.0 and Spark with included jre on Windows (10) .
Since Spark 2.9.3 (and in 2.9.4). I can not receive a message from another spark client.
I see the activities (USER is typing, etc.) and a message box pops up, but there is no message.

To test/show, I had a client using spark 2.9.2 client (“A”) message with a client (“B”) running 2.9.4.

Client A sends message to B. Message shows in Client A and box pops up on B, but is has no message.
Client B responds to A and message shows up in both A & B.

Also, I noticed that the message window in 2.9.4 (B) does not show the Green Dot/username in the top/tab. It’s just a small stub. Also, when I close the message window, most of the display leaves, but the window does not close. I have to logout/exit Spark to get this window to close.

Any Ideas on what I should try/test ?

Thank you,
Joel

Here is a picture showing the 3 screens - A is the 2.9.2 client that can see all messages, B is the 2.9.4 that only sees it’s own messages and has the missing username/green icon, & the last box is what happens when I try to close the 2.9.4 chat window.

very strange, I have 200 users, no one has lost messages. and you can delete the Spark folder from the profile of two users (appdata \ spark) and try again

This can happen if you update older 2.8 version of Spark with 2.9 version on top. You need to exit Spark and delete older plugins in user Spark profile at C:\Users\User\AppData\Roaming\Spark\plugins.

I upgraded Spark 2.8.3 to Spark 2.9.3 and after upgrade I removed plugins folder from %appdata%\spark folder. So I think wroot is right.

Hello, thank you for the tip about plugins, that is what I needed. My problem IS an old plugin! I use meet.jar (Pade Meetings Plugin 0.0.5).
I use the Spark installer exe that includes jre. Is it supposed to include a new version of the meet.jar ?

Several weeks ago I had trouble getting the Meetings plugin to work (really to figure out how/where to install it) so I downloaded the one that wroot posted in this thread: SparkMeet (video chat using OpenFire w/ ofmeet.jar)

I guess now I wonder - where can/should I be downloading the latest meet.jar for Spark? The one I have seems to be out of date/not working with Spark 2.9.3+ ?

Thank you for all of your help.
Joel

I think it was going to be included with 2.9.3 (until it was removed because of issues). So it should work with 2.9.3 version. At least it was working, as much as i can test without actually making a video conference, and there were no issues with chat when i tried it in 2.9.3 nightly builds. Maybe @Dele_Olajide can say if he has plans to work on this plugin at some point.

I don’t think I can fix the issue of how big the embedded Chrome browser is. I have tried Electron, jxBrowser and jCEF and they all introduce a big file that has to be loaded into Spark.

Developing a native java audio/video solution from scratch when everyone is using the free, mature webrtc media stack in Chromium is not feasible.

The issue was not with the size, but with how Spark deals with such huge plugins (locks up, loads longer). It is probably possible to improve that, but maybe not Dele should do that. Opportunity is open for any developer contributor to work on that. I just wonder if Spark is capable of “lazy” loading a button on toolbar in chat window while plugin is loading on the background. So it won’t lock up UI until it is loaded. But i guess currently you would have to reopen the chat window to get the button, if you open it too soon while plugin was still loading.

Loading the chromium runtime files in a new background thread might solve that. That is a very good idea and I could take a look at doing that :slight_smile:

I have implemented the idea as suggested by @wroot and submitted a PR

There is no freeze or slugish behavior when I tested.

I also fixed a NPE error in the meet plugin and fileupload that both depended on an removed package for base64 decoding.

1 Like

Thanks Dele! I will merge and test them later today.

I have tested this change. Now Spark UI is not locking up on a first login while Electron files are being downloaded on the background. Pade button is still being shown in the toolbar and if you press it, it sends the meeting URL. After download finishes it also opens an Electron window when pressing this button. I guess this is not a major issue. Don’t think anyone will rush doing video calls during first 15-30 seconds after a login :slight_smile:

If anyone wants to test this, give this build a try https://bamboo.igniterealtime.org/browse/SPARK-NIGHTLY-1590/artifact/shared/Install4j-generated-media/