powered by Jive Software

Spark client account registration fails -- what am I doing wrong?


#1

I have installed Spark and can access the admin control panel from another PC on the network, but when I try to create an account I get an error that says “Unable to connect to [servername]”. I opened TCP ports 5222,5223,5269,7777,9090,9091 on the server and checked and the service is running. I started the server and it shows up in the system tray. What am I doing wrong?


#2

What versions of Openfire and Spark? Have you enabled Inband Account Registration in Server Settings > Registration & Login? What is your xmpp domain and what you put in Spark as a server? You can also check Spark logs at C:\Users\User\AppData\Roaming\Spark\logs (and maybe also Openfire logs).


#3

My first concern would be that you’re mixing usage of the XMPP domain name, and the fully qualified domain name of the server that is running Openfire.

The XMPP domain name is how, via XMPP, you identify your XMPP service, but also your users (eg: “example.org”, "robert@example.org")
The fully qualified domain name of your server is its DNS name, typically configured in an DNS A record (eg: “myserver.example.org”)

The two values can but need not be the same. You can find both values for your XMPP server on the first page of the Openfire admin console after you logged into it.

When you log in with Spark, Spark will interpret the value that you use as an XMPP domain name. In order to determine the fully qualified domain name of the server (where it needs to connect to), it will:

  1. Use the manually provided values, if you disabled “Automatically discover host and port” in the Advanced Connection Preferences of Spark.
  2. Attempt a DNS SRV lookup (using the _xmpp-client service identifier)
  3. Attempt to use the XMPP domain name value as the fully qualified domain name (works when the XMPP domain name and fully qualified domain name are equal)

#4

I figured it out after some searching online. I had to go into the Advanced tab under the client and tick the box for Accept all certificates.


#5

Well, you also need that setting to be able to login also, if you are using self-signed or untrusted certificate. But as you were only registering you haven’t tried to login yet.


#6

As soon as I changed that setting I was able to create an account AND log in.