powered by Jive Software

Spark Client setup error, Can't connect to server invalid name or server not reachable

I am new to OpenFire/Spark. I have installed all of these items below locally on my PC with admin rights

I installed MySQL and created my DB CHAT_DB

I installed XMPP and have Apache and MySQL services running

I installed OpenFire, login fine, and have localhost as my servername

I created my own username

I installed Spark locally, use localhost as my server – chat window opens without issues.

I have installed Spark on another computer in the network, who I am able to ping its IP address

I created a new user for this computer - able to connect with new user login on my own computer’s Spark installation

I am now trying to connect on new computer with new user login

What is the Server value?

I have tried my own computer’s IP address, computer name…to no avail. What am I doing wrong, or have not done.

Again, I am all new to all of this, and would like some baby steps help, please

What does ‘installed XMPP’ mean?

What error do you get when you connect by IP address? Do you have the firewall disabled on the system?

Does the system you installed Openfire on have a hostname setup in DNS, that other systems on the network can use to access it?

Thanks for the quick reply.

I meant installing XAMPP to run the Apache and MySQL services. I have only installed this on my PC in the network, for testing. So all installations: XAMPP, MySQL, OpenFire, and Spark are now on my computer using localhost as the server name.

The error when I tried to connect from another PC, and I can ping by IP and name to my PC from that one, I get the error = Can’t connect to server, invalid name or server not reachable.

The PC where OpenFire is installed and connected is on the DNS, so is the other PC (they can ping each other by name and IP).

Now, when I open my Spark client, I use the server localhost. What should I do on the other PC so that I can reach my localhost server?

Thanks again in advanced.

If you put the system’s LAN ip in the ‘server’ field, does it work? You said you can ping it by name from another system - Have you tried using that name?

Have you verified the firewall is turned off or allows tcp/5222?