powered by Jive Software

Spark Crashed on Windows 8

Hi Openfire Team,

We are using Openfire 3.7.1 on unix box (centos). Recently, i installed my spark on my Laptop which is having windows 8 configured. It worked fine for some days. And today, all of a sudden spark crashed. when i re-logged in, i saw all my roaster contacts are lost .

Please help me here.

Let me know, whether you require any logs,etc to dive deeper into this. If so, please can you tell me where would the spark logs stored in windows 8.

Thanks & Regards,

Adhiraju Mouli

which version of spark are you using?

it sort of sounds like your spark user profile (in %APPDATA%/Spark) is corrupted. Killing that directory and then restarting spark may fix it. (it will also kill all your transcript logs, and anything else that is profile-specific. So maybe make a backup.

Hi Jason,

Sorry, the actual issue was user was not able to send messages nor able to recieve messages. All his roaster users/friends have gone offline. Further, i have also deleted transcript logs (C:\users<user id>\AppData\Roaming\Spark\user) but then no luck .

Further, today after igniterealtime.org downtime. i downloaded the latest version 2.6.3 and installed but again no luck

I am wondering, whether spark 2.6.3 supports windows 8 ? if so were there any issues/bug’s been identified ?

Please help.

PFA below error logs

Error Log:

SEVERE:

No response from the server.:

at org.jivesoftware.smackx.PrivateDataManager.getPrivateData(PrivateDataManager.ja va:209)

at org.jivesoftware.sparkimpl.plugin.scratchpad.Tasks.getTaskList(Tasks.java:205)

at org.jivesoftware.sparkimpl.plugin.scratchpad.TaskNotification$2.run(TaskNotific ation.java:73)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

SEVERE:

No response from the server.:

at org.jivesoftware.smackx.PrivateDataManager.getPrivateData(PrivateDataManager.ja va:209)

at org.jivesoftware.sparkimpl.plugin.scratchpad.Tasks.getTaskList(Tasks.java:205)

at org.jivesoftware.sparkimpl.plugin.scratchpad.TaskNotification$2.run(TaskNotific ation.java:73)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

Warn log:

WARNING: Exception in Login:

Could not connect to ignite.techmahindra.com:5222.: remote-server-timeout(504) Could not connect to ignite.techmahindra.com:5222.

– caused by: java.net.UnknownHostException: ignite.techmahindra.com

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:517)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

Nested Exception:

java.net.UnknownHostException: ignite.techmahindra.com

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at org.jivesoftware.smack.proxy.DirectSocketFactory.createSocket(DirectSocketFacto ry.java:28)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:512)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

WARNING: Exception in Login:

Connection failed. No response from server.:

at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:119)

at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:568)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:527)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

–> repeated couple of times then,

WARNING: Exception in Login:

Connection failed. No response from server.:

at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:119)

at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:568)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:527)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

WARNING: Exception in Login:

XMPPError connecting to ignite.techmahindra.com:5222.: remote-server-error(502) XMPPError connecting to ignite.techmahindra.com:5222.

– caused by: java.net.ConnectException: Connection timed out: connect

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:524)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

Nested Exception:

java.net.ConnectException: Connection timed out: connect

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(Unknown Source)

at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at org.jivesoftware.smack.proxy.DirectSocketFactory.createSocket(DirectSocketFacto ry.java:28)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:512)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

Thanks & Regards,

Adiraju Mouli

**
**

**
**

hmm, well, it’s not connecting to the server (and hence no contacts showing, etc).

Try this beta build: http://www.igniterealtime.org/builds/spark/dailybuilds/spark_2_7_0_648.exe

If same thing, then I’d wager something is wrong with your setup. I use Spark on win8 with no problems.

Make sure the server has that user setup, with the correct password and is allowed to see other contacts, etc… normal sanity checks.

Unknown-host-exception ignite.tech,.com sounds like a local setup/dns problem.

Hi Jason & LG,

As suggested, during sanity check i was not able to resolve username from OPENFIRE Admin Console (Users/Groups --> Advanced User Search) tab.

Later, I have setup a DR (Disaster Recovery) for Openfire Server and then tried to search/resolve username and this worked .

Now, i am confused. What to do

Today, late night i will take a bounce of Production Box but, yet again wondering what could be the problem. Is there anyways to tweak this issue without Bounce of OPENFIRE service on Production Box.

Please help.

Regards,

A.H.V.K. Mouli