powered by Jive Software

Spark does not work IBB or Proxy security.

(en)Hi all!
The next question. I use Spark version 2.8.3.
To transfer files I want to use the IBB protocol, which categorically refuse to work in this version of Spark.
Perhaps it can be repaired somehow and who knows how?

As an alternative, you can use Proxy (7777) but I’m concerned about the security of file transfer.
Can a proxy be considered safe from MITM attacks? Files in the transfer are not encrypted in any way?

Thanks to all.

(ru)Приветствую всех!
Вопрос следующий. Использую Spark версии 2.8.3.
Для передачи файлов хочу использовать протокол IBB, который категорически отказываться работать в этой версии Spark.
Быть может его можно как-то починить и кому нибудь известно как?

Как альтернативу, можно использовать proxy(7777) но меня беспокоит безопасность передачи файлов. Можно ли proxy считать безопасным от атак mitm? файлы при передаче ведь никак не шифруются?

Всем спасибо.

I think you were suggested in chat to try 2.9.0 nightly version. Was it better? I think speedy had a fix for IBB. But i can’t say when 2.9.0 could be released. Development is stalled currently.

Thanks for the answer. With the night version 2.9.0 did not become better.
I hurried with the answer in the chat. Having checked everything carefully I can say for sure that in version 2.9.0 the problem unfortunately is still observed.

Спасибо за ответ. С ночной версией 2.9.0 лучше не стало.
Я поспешил с ответом в чате. Проверив всё внимательней могу сказать точно, что в версии 2.9.0 проблема к сожалению по прежнему наблюдается.

I don’t have Spark here, but there should be a checkbox to force IBB in the preferences. I don’t remember if it is enabled by default. So, check that first. If the problem still persists, please describe your environment (same subnets or not, NAT, etc.). I will file a ticket then, but that’s it. Spark doesn’t have developers, so i doubt someone will look into such network/transfer issues soon or ever.

(en)No, the checkbox unfortunately does not exist in the settings.
The connection in the test environment is as follows:
3 pcs. 1 server and two hypervisors.
1 - server. (192.168.0.1)
2 - PC1 NAT (10.8.0.0/24)
3 - PC2 NAT (10.8.10.0/24)

I was told at the forum by one wonderful xmpp client “Jitsi”, which has already tried and can say,
that everything works there! Even sip telephony works correctly.
But I ran into the following problem. This client does not understand the / etc / hosts file
And now I’m working there to figure it out.
I think this client is a way out of this situation.
Perhaps you will advise some other worthy alternative customers?

(ru)Нет, флажка к сожалению в настройках нет.
Подключение в испытуемой среде следующее:
3 ПК. 1 server и два гипервизора.
1 - server. (192.168.0.1)
2 - PC1 NAT(10.8.0.0/24)
3 - PC2 NAT(10.8.10.0/24)

Мне на форуме подсказали один замечательный xmpp клиент “Jitsi”, который уже опробовал и могу сказать, что там всё работает! Даже sip телефония работают корректно.
Но столкнулся с следующей проблемой. Этот клиент не понимает файл /etc/hosts
И сейчас занимаюсь там, чтобы с этим разобраться.
Думаю этот клиент - выход из сложившейся ситуации.
Быть может Вы посоветуете еще какие нибудь достойные альтернативные клиенты?

The setting is only in the 2.9.0 version and is in Preferences > File Transfer (In-Band Bytestreams Only). At least in my virtual testing environment it helped to fix failing transfers between host and virtual machines using NAT connections.

You can also try 2.7.7 version and use it until (if ever) this is fixed in the latest Spark version. https://github.com/igniterealtime/Spark/releases/tag/v2.7.7

Maybe Pidgin, Gajim or Psi will work for you. Why do you have to use hosts file though? Don’t you have DNS or something? That might also be the cause of this or other problems. Not sure as i have never actually tried to use xmpp with domains put into hosts.

And in fact, the checkbox is present!))
I turned it on and the transfer ibb earned !!)))
Only here is what a bug noticed in the extreme version … Do you also do not see the message if you send only one character?

I have two networks. In one there is DNS and everything that is necessary for the life of the network.
In the other, there is nothing of this and is not foreseen in the near future, and an instant messenger is needed there too.
That’s twisted with the help of the etc / hosts file.

И ведь действительно, чекбокс присутствует!))
Я его включил и передача ibb заработала!!)))
Только вот какой баг сразу заметил в крайней версии… У Вас тоже не отображается сообщение если отправить только один символ?

У меня две сети. В одной есть и DNS и всё, что необходимо для жизнедеятельности сети. В другой же ничего этого нет и в ближайшее время не предвидится, а мессенджер нужен и там.
Вот и выкручивался с помощью etc/hosts файла.

Yes, that’s a known bug https://issues.igniterealtime.org/browse/SPARK-2043

that is, in principle, if you look at the nightly assembly, you can say with certainty that the main problems have been noticed and eliminated.
It remains only to wait for a stable release and I’m sure it will be good. True, unfortunately, such a release may not come out very soon.

can someone know which file in version 2.8.3 needs to be edited, so that the ibb only option is available? In the rest, the client 2.8.3 completely suits me.

from the file% appdata% \ spark \ spark.properties tried to move the parameter “fileTransferIbbOnly = true” to version 2.8.3, but it just does not work so much :))

Yeah, it’s a bit more complex to add new feature than editing the settings file :slight_smile: If you are familiar with programming then this is the code commit introducing this change https://github.com/igniterealtime/Spark/commit/8db1a6520f0c5d88b48c7f9269310eb5b2d630dc but you have to edit source files and then compile new version. You can’t edit binary files in Spark installation to achieve that. If you manage to compile it, you can then get spark.jar file which you can copy into every installation replacing original one. There is a chance it won’t work though, as source version of Spark might had more changes before that commit which might be required. It seems that it is best to wait for 2.9.0 release. But i can’t say when.