Spark File Transfer error


We are configuring an Openfire 3.0.7 - cum - Spark 2.6.0 (Server / Client) for our company

We had previously configured it very well & it was working also fine, however the openfire and spark client server systems went down

So this time we are setting up the whole Client / Server system again. It was set up successfully with one loop hole

FTP does not seem to be running well

It gives an error saying that “An error occured during file transfer”

We tried many ways to rectify the error; like :-

  • Installed a Virtual Machine and then created another Spark client there. File Transfer on the same machine is not giving an error. But when it is on the network, then an error occurs in the file transfer

  • Reconfigured our firewall and unblocked port number 7777, no solution

  • Created a simple P2P connection between 2 machines, still there was an error

Can anyone let me know the reason for this issue and how could it be rectified

For testing purposes, please check with the pretty old Spark 2.5.8 available here:

The clients try three different ways to send files:

  1. Peer to peer transfer via port 7777. This is not working, if you have a desktop firewall (like the one in W7)

  2. If Openfire acts as media proxy, the client tries to send on port 7777 to the openfire server and the server streams the file on 7777 to the receiving client. This is useful, if the sending client can not reach the receiving client due different network segments that can not reach each other on client level.

  3. IBB file transfer. The sending client encodes the file into characters like uuencode and sends the file as chat messages to the client via the server. This is broken in 2.6.0 to 2.6.3 and currently under investigation.

1 Like

We have the same issue with at least my own client.

I can send , but not receive anything anymore. What i do as a workaround , i wait a while then open the file from the folder where it downloaded to.

Strangely , others with 2.6.3 have no Problem in our Network…

I posted that error some weeks ago , no answer gotten, so i thought it´s my PC´s own Problem. Reading it has struck others too…i want to hook in again…

I speak German, if one of trhe devs would want to contact me for testing something …



Please check the experimental Smack posted on and report the results. Thanks


I downloaded Spark 2.6.3 & Spark 2.5.8 and I found that the File Transfer Error was solved!

So now as per our company’s requirements, I need a link from where I can download the source code and customize it according to our needs. Can you help me in this matter?