Spark hanging at authentication

A user has the improper credentials entered in spark and it is just hanging, it won’t reject them.

Autologin is selected, so anytime i try and open the program it attempts to auto log in.

I have tried restarting the machine, checking the folder permissions, and reinstalling spark.

Any suggestions would be excellent. Thanks in advance.

Try to remove the line “autoLogon=true” in the file located in the users home folder. It should clear the auto logon issue

1 Like

Thanks so much! that solved the problem, but we restarted the machine for a software update and now spark will not launch at all, I can see it open in the task manager processes and then it immediatly shuts down, the log in window never opens.

Try removing user’s Spark profile folder completely (you can save the history of chats and then copy it back, when new profile is generated). Also you can try 2.6.0 RC1 version

If you have Kerberos running on your system and u auth with that and is using 2.5.8, spark will not launch if spark cannot finds it´s credentials for kerberos.

To solve use “klist purge” to remove all kerberos tickets and then use “kinit” -> enter users password, and authenticate the user again towards kerberos and spark should be running fine again, alt just reboot the computer after that.