powered by Jive Software

Spark hangs while log off from Terminal-Server 2012R2

Hi!

We are using Spark (2.6.3) and Openfire (3.8.2) as IM.

Now we are switching from normal PCs to a Terminal-Server 2012R2 and Citrix XenApp/XenDesktop environment.

The problem is now, that when Spark is running on the Termianl-Server and the user is signin off the sign-off-process hangs.

I have to kill the terminal-session manually. I think this problem depens on Windows Terminal-Server 2012R2 because we have tested it on Windows Termial-Server 2008R2 an there it works.

the problem only shows up when the user is or was signed-in in Spark. When Spark only is started but not logged in signin of from Windows was no problem.

I’ve also tried to exit Spark before signing off Windows but here it hangs also.

Does anyone have these problems?

MfG Bernd

Spark will probably also be more sluggish while running in the terminal environment. We’ve been on this path and decided to move back to physical machines. Not because of Spark, but in general because of sloppy performance via RDP. Terminals make me shrug now

You can use the latest Spark build and see if it fixes the issue http://www.igniterealtime.org/downloads/nightly_spark.jsp

well, server 2012 is similar to windows 8/8.1 regarding how it’s handling processes and the like. i’ve not used server 2012 myself, but i’ve used a lot of windows 8/8.1.

When you go to logout or shutdown, windows will wait for the processes to “finish” before it fully logs-out/shuts-down. It’s possible windows thinks spark is still doing something since spark has normal network activity at most times… and therefore it never fully terminates it.

i believe there is a setting/config somewhere that you can have windows only wait a specified number of seconds before just clobering processes and shutting them down.

Hi!

Do you konw where to find this setting?

Greets

i haven’t had the need to do this on my setup… but in previous versions of windows you would edit:

HKEY_CURRENT_USER/Control Panel/Desktop

     --> Wait To Kill/ App Timeout

I believe the timer was in milliseconds.

But, be aware this could cause unexpected side effects…

Another possible solution, if spark is the only thing windows gets stuck on… you could write a script that forces it closed when a user logs out.

The Nighly Build version has the problem too.

Is this a problem the developer fom spark already know?

Will it solved in the foreseeable future?

I don’t think, it is a good idea to change the registry… :wink:

Maybe a Log-Off-Script is the solution to kill the Spark process.

The last optinion is to use a other client (Pidgin or someting else…) but I like Spark and Spark is to openfire full compatible…

Currently there is practically zero active spark developers (no offense snake ), and this issue is very specific (terminal env., new os), so i wouldn’t hope for a fix soon, if ever. Some script is your solution for now i think.

@Bernd I do not have this problem on machines, windows 7 and 8. Wroot’s right, there must be something specific to your terminal services environment.

Just so we’re on the same page, you already tried build 653 using the embedded jre?

http://www.igniterealtime.org/builds/spark/dailybuilds/spark_2_7_0_653.exe

Yes. Exactly this version.

Maybe helpful?

http://social.technet.microsoft.com/Forums/exchange/en-US/e84f43ef-e14c-4025-a68 7-ce65c723ea7c/server-2012-rds-user-session-cannot-be-logged-off-or-disconnected -shows-as-active

http://www.chicagotech.net/remoteissues/rds2.htm