Spark linux cannot resolve hostname in SERVER tab

Hi, Ive started Spark 2.5.8 and when I try to login to server with hostname addres I get an error invalid name or server unreachable. When I type IP addres it works, why is that ?

host name resolution is dependent on the DNS setting of the host operating system. Can you get to the admin page for the server from the same machine. it should be the same name you enter into spark followed by :9090 (i.e. Is the openfire server name a fully qualified domain name? If it is not it will not lookup.

Thank you mtstravel,

I CAN go to server page with “centos.titel.wi” , this is my local zone and network. I is fqdn and only SPARK is acting this way, other jabber clients work with no problems, in log there is

WARNING: Exception in Login:

Could not connect to centos.titel.wi:5222.: remote-server-timeout(504) Could not connect to centos.titel.wi:5222.

– caused by: centos.titel.wi

But my DNS is working I can ping ‘centos.titel.wi’. . .

when you configured your openfire server what was the name you gave it? Is it a FQDN?

Yes it is. Like I said, SPARK in windows works, other clients work, just SPARK for linux, I can connect using IP address but not with name.


does “nslookup centos.titel.wi” return the IP address of your server if you execute it on your linux client?

Spark should be able to resolve the name as long as your client can resolve it.


Yes, it can.

I have all these things setup and working for 3 years, now I just want to replace jabberd2 with openfire, I have many linux clients on Ubuntu.

Like I said, OTHER jabber clients work, so no point checking DNS it works. But nevermind, Ill use pidgin like before and ejabberd

I have the same issue. I tried using both the internal acutal machine name which is in MS DNS and the ouside DNS name. Neither work in the linux client while ip addresses do. The client machine resolves hostnames properly. It seems like there is an issue resolving hostnames in the linux client. I am running it on an Ubuntu client, but I’ll also try it on a Fedora box.

I even tried putting the hostnames directly into the \etc\hosts file which fixes the issue.

markotitel wrote:

Ill use pidgin like before and ejabberd

Pidgin works with Openfire, you know

If you are talking to me I know that, but we are going to standardize on Spark because we want to force people to use our gateways and we want to block any transfering of files. Pidgin is great and I use it, but we can’t control it.