powered by Jive Software

Spark locks up workstations

Hello all! We have an odd problem with Spark and some of our XP boxes. The problem persists with any version of the Spark client and any version of Wildfire/Openfire. It completely locks the workstation when a user receives a message…again this is only on some of our XP workstations. We have compared OS patches, user progam versions and patches and a host of other items and nothing appears to stick out as the culprit. We are using the latest version of Openfire which I upgraded earlier this week and I have upgraded several users to the latest version of Spark (2.5.7). The problem does not follow the user when we move them to a different workstation.

Thanks for any help,

TL

I am sorry to say that it sounds like an issue with your OS on those particular machines.

yeah I think that may be the case too but just wanted to see if anyone had encountered a similar problem. I’ll probably reload the OS on one of them and see if it helps.

Thanks,

TL

Hi Tim,

can you still use the task manager to kill Spark?

Maybe it’s a problem with Direct3D or your graphics card driver. There should be some settings like “Enable Hardware Acceleration” but I don’t know if this helps. You may also want to take a look at http://www.igniterealtime.org/community/message/111006 and Spark JVM Settings.

A “Spark.vmoptions” file is the easiest way to add “-Dsun.java2d.d3d=false” to the Java/Spark process.

LG

Updated the video drivers and java for each of the stations and created a “Spark.VMOptions” that is logging to Spark.gc.log. Unfortunately this has not solved the problem. One thing I noted is that one of our supervisor users has the problem with three users while another supervisor has the problem with two other users. Otherwise we can all message around as needed.

TL

Hi Tim,

did you add only the options to log GC or also -Dsun.java2d.d3d=false to the Spark.vmoptions file?

LG

I used all of the options you provided and put “-Dsun.java2d.3d3=false” as the first line of the file (did not use quote marks in file). I have also downloaded 2.5.8 which I will push out over the next few days.

Thanks,

TL