Spark: Login Issues

So, I finally managed to get my Openfire server installed properly and got it to recognize and find users in my active directory using LDAP. Currently, Openfire recognizes all seven of my users in active directory. Now, I have spark downloaded on three separate machines and can’t log in to any account from any machine. Am I just missing something? I have tried everything I can think of as far as resetting passwords, resetting machines and applications, and trying every format for the Server field. Sometimes Spark will sit there and say “Authenticating” for about ten seconds and then give me the error message: “Can’t connect to server: invalid name or server not reachable”. Other times, it doesn’t spend any time authenticating, it just goes straight to the error message: “Invalid username or password”. I think my format for the Server field is messed up. The username and password fields are not the issue, as I have updated them today and know the current passwords for all of the users. The “Save password” box is not checked.

What is the proper format for the Server field? The server that holds Openfire is named Also, do I need to change any of the advanced settings? Currently they are all default. Any help is appreciated!

You can try putting IP address of that server in the Server field. Also, is firewall turned on or off? If on, you need to add an exception for 5222 port.

It was a firewall issue. I made new rules for that port and it worked like a charm. Thanks for the advice!