powered by Jive Software

Spark não loga no servidor


#1

Boa tarde Amigos,

Instalei o Servidor do Openfire no Debian 8.5 , o mesmo esta rodando perfeitamente na minha rede. Consigo entrar pela rede normal.

Mas quando nas estacoes que instalo o spark para conectar o mesmo fica somente dando Username ou password incorreta.

Nao sei se o problema esta na liberação da porta 5222 no próprio servidor linux.

Agradeço antecipado a ajuda.

Franzé Gurgel


#2

Boa tarde Franzé, abri um post com a mesma questão, ontem tanto eu quanto o Vinicius descobrimos o que possa ser o problema, no ambiente do Vinicius ele utilizou no local do servidor spark o nome do host ao invés do IP do servidor, no meu caso eu instalei a versão 2.7.5 do spark ao invés da 2.8 e funcionou. Espero ter ajudado


#3

Boa tarde, Wellington,

Amigo já havia feito este teste e realmente nao funcionou. O que noto e como se ele não estivesse achando o banco.

Eu não usei o sql, fiz com a instalação mais simples usando o banco interno do próprio OPENFIRE.


#4

Boa tarde amigo. ainda está com esse problema?

Não entendi direito, na sua rede interna o spark funciona e somente na rede externa ele não funciona?


#5

Boa Tarde!!
Estou com um problema semelhante, mas eu estou usando o Windows 7 Professional.
O openfire e o spark são instalados com sucesso, porem não consigo conectar o spark ao openfire.

Eu crio os usuários no openfire e quando vou tentar logar com o Spark fica dando “Username ou password incorreta”.

Eu uso uma rede interna com um roteador da NET.

O quer será que está errado?

grato pela ajuda!


#6

Boa tarde amigo, qual versão do openfire você usa? Tinha um problema em uma das versões e dai em vez de conectar pelo IP do servidor do openfire, você tinha que colocar o hostname, dai tem que verificar o DNS das maquinas para ver se elas resolvem certo o hostname do servidor.


#7

Obrigado por responder Vinicius!
Eu trabalho em uma pequena empresa que disponibiliza de um modem wifi da NET e portanto a rede é unica e local. Existem alguns computadores de mesa conectados a essa rede local e o que eu estou tentando fazer é criar um servidor openfire simples e básico no meu PC e depois instalar o spark nas demais maquinas. A instalação de ambos os programas são concluídas com exito, porém não consigo me conectar me conectar ao openfire pelo spark. Não estou usando um servidor AD e nem de DNS, tento me conectar ao servidor openfire pelo IP ou pelo hostname da maquina, porém sem sucesso e aparece a mensagem: “impossivel conctar 127.0.0.1”

eu uso o Spark 2.8.2 e openfire 4.0.4

Sou meio leigo nessa parte de redes.

agradeço pela ajuda desde já!


#8

Bom dia Samuel, desculpe a demora em responder, vamos tentar te ajudar, você instalou o openfire no teu computador, e está tentando conectar dele mesmo?

Se você estiver tentando conectar dele mesmo, você tentou pelo ip interno dele ou pelo 127.0.0.1? Teria que ser pelo ip dele, não pelo loopback (127.0.0.1), dai se você tiver um ip fixo, por exemplo: 192.168.0.1, coloca esse ip no servidor do spark.

Se você estiver tentando conectar de outro computador, verifica o firewall do Windows do teu computador que você instalou o openfire, ele tem que estar desativado.


#9

Olá Vinicius!
Desculpe a demora.
Sim, eu estou tentando conectar o Spark no servidor Openfire no mesmo computador e também tentei conectar o ao Openfire por outro PC através do Spark.

Eu tentei pelo ip 127.0.0.1 e pelo nome do servidor Openfire, eu criei os usuários no Openfire e quando tento logar pelo Spark apareceu a mensagem “Invalid username or password” e quando tento criar uma conta no Openfire através do Spark aparece a mensagem “Impossível conectar”.

Desativei o firewall do antivirus e do Windows e mesmo assim não consegui.

Será que é porque eu uso um sistema operacional que não é um servidor AD?

Agradeço mais uma vez meu amigo.


#10

Bom dia Samuel, você instalou qual versão do openfire e qual versão do spark?

Tem um problema ao conectar pelo IP, tem que marcar uma opção no Spark para aceitar qualquer certificado e se você tentar conectar pelo nome, se o DNS da maquina não estiver correto ele pode não conseguir resolver e não vai comunicar com o servidor do openfire. Tenta conectar pelo IP e verifica nas opções do Spark antes do login se tem a opção de aceitar os certificados.Outra coisa, você fez uma instalação básica, não tem integração com AD, quando você loga no console web dele de administração, aparece normal os usuários lá?


#11

Bom dia,

Samuel Nao sei se resolveu seu problema, mas estava como o mesmo problema não conseguia conectar com o servidor, estava usando a versão do spark_2_8_3, ai eu instalei a versão spark_2_7_5 ai funcionou certinho, tenta ai.


#12

Estava com o mesmo problema, pesquisei um pouco, e descobri que o problema era essa versão do spark 2.8.3, instalei a 2.7.x e deu certo, porem eu insisti em resolver o problema, e consegui usar na versão atual o spark.

Na opção “avançada”

  • IP/porta manual.

  • Aceitar todos os certificados(accept all certificates(

Na primeira Tela

  • usuário

  • domínio( o domínio que você escolheu, caso tenha duvida no domínio clica na setinha que tem ao lado da caixa de usuário, clica na seta e seleciona.

abrç.

Bruno.

Tecnólogo em Redes.

suporte.inf@live.com


#13

Estou com o mesmo problema, mas na versão 2.7.7
Alguns usuários, se conectam… outros não.
Aparentemente só o de administrador.


#14

Eu configurei certinho, todos os testes foram ok.
Inclusive todos os usuários estão no painel, tudo ok.
base: DC=csalud,DC=br
filtro de grupo: (&(objectCategory=Group)(memberOf=CN=G_OPENFIRE,CN=Users,DC=csalud,DC=br))
Filtro de usuario (&(objectCategory=person)(objectClass=user)(memberOf=CN=G_U_OPENFIRE,CN=Users,DC=csalud,DC=br))