powered by Jive Software

Spark - No text visible in IM chat client

In build 2.0.8 I was able to see chat from my contacts and other members located in the chat room. However, with this new version, 2.5.0 the chat once it has been entered by me is no longer visible. However, my contacts and other people in the chat room are able to see my chat. Additionally, I am not able to see the other people’'s chat posted to the room or in direct messaging. Please any help would be beneficial. I am running Spark on Mac OS X v 10.4. Thanks.

I have a similar problem.

When opening a chat window the message I type stays in the entry box at the bottom even after pressing . The text does not appear in the main chat area but my name does.

Attempts to enter more text just result in my name being repeated.

I can not see the words typed by the other users.

I am also unable to launch a chat window with one of the external MSN users on my list but can for every other one.

This problem was solved with the release of 2.5.1.

I am having this exact same problem with spark 2.5.8… any suggestions?

Additional info, I have to close the window for the user I am sending text to or receiving it from to be able to view it.

Yeah, me too and I posted it on here with no resolution. I think it started happening when i went to 2.5.5 or 2.5.7

Here is the error log: (I am on spark 2.5.8 and openfire 3.4.3). I’ve just noticed the person having the issue has java 5 and 6 installed. i am going to remove all java and spark and reinstall

Jan 7, 2008 10:08:52 AM org.jivesoftware.spark.util.log.Log error

SEVERE: Error sending message

java.lang.NullPointerException

at java.util.Hashtable.put(Unknown Source)

at javax.swing.text.SimpleAttributeSet.addAttribute(Unknown Source)

at javax.swing.text.StyleConstants.setForeground(Unknown Source)

at org.jivesoftware.spark.ui.TranscriptWindow.insertMessage(TranscriptWindow.java: 167)

at org.jivesoftware.spark.ui.rooms.ChatRoomImpl.sendMessage(ChatRoomImpl.java:262)

at org.jivesoftware.spark.ui.rooms.ChatRoomImpl.sendMessage(ChatRoomImpl.java:248)

at org.jivesoftware.spark.ui.rooms.ChatRoomImpl.sendMessage(ChatRoomImpl.java:223)

at org.jivesoftware.spark.ui.ChatRoom.checkForEnter(ChatRoom.java:466)

at org.jivesoftware.spark.ui.ChatRoom.access$100(ChatRoom.java:73)

at org.jivesoftware.spark.ui.ChatRoom$2.keyPressed(ChatRoom.java:251)

at java.awt.AWTEventMulticaster.keyPressed(Unknown Source)

at java.awt.Component.processKeyEvent(Unknown Source)

at javax.swing.JComponent.processKeyEvent(Unknown Source)

at java.awt.Component.processEvent(Unknown Source)

at java.awt.Container.processEvent(Unknown Source)

at java.awt.Component.dispatchEventImpl(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)

at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)

at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)

at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)

at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)

at java.awt.Component.dispatchEventImpl(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Window.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

NO ONE else has had this issue?

I am really disappointed that this is happening with version 2.5.8 and i am having to go back to version 2.0.8.

I have been very pleased with spark and openfire up until now. I really didn’t want to have to pay for enterprise to get support to fix it.

So I’m going back to 2.0.8 for the time being.

I’m just surprised that no one else except us is getting this and no one can recommend a fix .

This same issue is effecting several of my users. I believe it’s related to SSO (and perhaps active directory?), as the users that are using username/password aren’t having problems. Still a bother, though, as the users that tried to use SSO and are now back to using username/password are still having the same problems. I could be completely wrong, but it is the only connection I have found between the issue and the users.

yeah, i rolled back to version 2.0.8 and the issue doesn’t occur. all of my users use sso against ldap.

Do you know of a repository for older versions of Spark?

i don’t know how to view the repository, but from another post i grabbed a link to download 2.5.1 and i changed the url to 2.0.8 and it worked. here is the link to get 2.0.8

http://www.igniterealtime.org/downloads/download-landing.jsp?file=spark/spark_2_ 0_8.exe

au contraire mon frere

it began with 2.5.1

problem doesn’t exist in 2.0.8

Experienced the same issue described as above with no text visible in the chat window. We were about to roll out a skinned version of Spark IM 2.5.8 to our Mac users who are all running OS X 10.4.11.

Using version 2.0.8 works fine. All of our Macs are bound to Active Directory and users authenticate against ldap.

Have you figured out how to turn the “upgrade client” notification off for 2.0.8? It comes up everytime spark starts up.

you need spark manager. that gives you control over the updates. it will look at what you setup in spark manager for updates.

i attached the .jar file you should copy it into your plugins directory

then you’ll have a section on your admin console gui towards the bottom that says Spark Manager

copy the .exe for 2.08 into the resources\spark\builds directory or something similar.
sparkmanager.jar (16466 Bytes)

Works like a charm, thanks.

create a new local windows user profile hope your problem will be solved…

This is the exact issue i am having. yesterday it worked fine on my windows 8.1 pc.

But not working on my new win 10 laptop. at first was using the newest version. uninstalled and used the one from my company link on this site which was 2.8.0. But still having the same issue. I can see time stamp but not what people are saying. Also noticed under appearance the emojis show a red x and doesnt give option to change like it did on my previous pc