powered by Jive Software

Spark not sending or receiving messages

Hi Folks,

I’m new to the forum, and I tried to search to see if this question had been asked but was unsuccessful. So if I simply missed it, please accept my apologies. I am using Spark and Openfire at one of my clients as a testing facility. So far I have to say, WOW! What an awesome combination, and what incredible features available. Excellent work developers. But I have a single station where I’m experiencing a strange problem. The client logs in to the messenger automatically, but he isn’t receiving live messages. He tries to send, but they aren’t showing as going out. He then logs out, restarts Spark and he can see where people have sent him messages in the archive/history.

I have uninstalled and reinstalled twice.

I have changed his user name.

I tried to find an older version (or newer but I have the latest version on their systems) but I couldn’t.

I’m at a loss here folks, and any guidance would be welcomed. I really love this combo, and am excited to roll it out to my other clients, but I need it to be stable before it hits my base completely. Thanks for the amazing system.

Edit to Add:

Oh I forgot to add:

OS: Windows 7 Professional 64bit

Server OS: Server 2008 R2 64bit

Hello,

I am actually having some of the same problems. I installed java update 45 and was able to log in but it defaults to “invisible” what java version do you have on the client PC?

Hi Sal,

Same version. As a service, I offer my clients a monthly scanning of their systems. You know run CCleaner, run Malwarebytes, install updates, make sure the AntiVirus is running. Well this client uses that service, and today I’m doing October’s scans. I have found an interesting coincidence today. While running CCleaner, this machine complained that Google Chrome wasn’t shut down so the cleaner couldn’t run. But there was no Chrome browser running. When I told it to force close Chrome, it restarted Spark. So, I’m wondering if it doesn’t have something to do with Chrome being the default browser on his system?

I have uninstalled Chrome and will monitor it, to see if that plays any roles in this issue. Thanks for the reply Sal.

1 Like

First, you can try wiping this user’s profile and starting with a fresh one.

C:\Users\username\AppData\Roaming\Spark

But this issue can come back again. Usually it is related to corrupted history files, i think. You can also try the latest build (not official) of Spark http://bamboo.igniterealtime.org/artifact/SPARK-INSTALL4J/shared/build-665/Insta ll4j/spark_2_7_0_665.exe

I’m using it in production without issues.

Thanks wroot. I’ll give the latest version a try and maybe wipe things out like you suggested. I appreciate the feedback.