powered by Jive Software

Spark not working with Cisco VPN

We are having problems with spark when you open it while running the Cisco VPN client. The problem that we are having is as soon as it is opened it Kills the Cisco VPN Connection and closes spark. Does anyone have any ideas?

have you checked your cisco and spark logs files on the computer you are connecting from? Does this happen with every computer or have you only tried this on one computer?

I am using spark using the cisco vpn (as well as others in my co) and its working just fine. Also, after doing the above and still not figured it out, have you updated to the latest cisco client?

if nothing is getting logged for the cisco client you may need to enable these settings in your profile.pcf file:

EnableLog=

Determines whether to override log settings for the classes that use

the logging services. By default, logging is turned on. This parameter

lets a user disable logging without having to set the log levels to

zero for each of the classes. By disabling logging you can improve the

performance of the client system.

0 = Disable

1 = Enable (default)

Log > Enable/Disable

I have enabled logging and will see where it goes from there. Thanks for the tip.

Most likely, all of your network traffic is being routed to the remote network once you connect to the VPN. Because of this, you get disconnected from the XMPP server that Spark was connected to. You’ll probably have to disable the use of the remote gateway on your Cisco appliance in order to be able to stay connected to Spark and do other tasks such as browse the internet, check email, etc… when connected to the VPN.

Hi,

We had the same problem especially with Windows 10 clients with Spark 2.8.3. They were disconnected every 5-10 minutes. Windows X7 and X8 clients didn’t show this behaviour.

Looking at the server Openfire side, at sessions we saw that the Windows 10 VPN clients arrived with their WAN/External IP (e.g. 97.221.222.223) and the Windows X7 and X8 VPN clients with their VPN assigned IP address (e.g. 10.11.11.1, 10.11.11.2 etc.).

This has been solved by entering a line to the ‘hosts’ file of Windows 10:
c:\Windows\System32\drivers\etc\hosts (requires editing as ‘Administrator’)

The line needed was:

192.168.xxx.yyy spark.domain.com

Being:
NAT-ted LAN IP of our Openfire server service running at: 192.168.xxx.yyy
The (sub) Domain Spark is connecting to: spark.domain.com

Now also the Windows 10 clients arrived with a VPN IP address session, e.g. 10.11.11.3.

This took us months to find out. Either Windows 10 or Spark is malforming the IP that it is supposed to ‘use’ for the im session.

Added a new posting with more details:

Kind regards,
Suat

1 Like

this sounds like a slit-dns issue. perhaps windows 10 wasn’t resolving dns correctly over tunnel. it would have been curious to see if DNS was going on the public interface or the tunnel.