powered by Jive Software

Spark notification of new message

I currently have a small network for which I set up a server running OpenFire 3.3.2 to handle our internal IM traffic. Also, early last week, I created a policy to deploy Spark 2.5.5 to all of the client workstations in preperation for our switchover. So far, I’ve run into two problems that I’m not sure exactly what the deal with them is.

First off, I created an Active Directory group to handle our contact list for our users. Changed the settings necessary in OpenFire, and it works great except for two users. For whatever reason, these two users do not get the contact list published to their IM client, nor do they show up in anyone else’s contact lists. I’ve tried taking them out of the AD group, waiting for OpenFire to update the list, then put them back into the group, but no luck there.

My second problem, and this I’ve seen somewhat inconsistant results with, is trying to setup spark to notify the users when they get an IM. On two workstations I was able to get spark to flash on the task bar when they get a new IM (the ideal setup). I did this just by checking the “Bring window to front” option in the preferences. However, for whatever reason, this doesn’t work on everyone’s machine.

Anyone have any thoughts on how to fix eather of these?

A little info about my setup here… All of the client machines are running Windows XP w/Sp2, and Spark 2.5.5. (I can’t deploy 2.5.6 yet due to the missing .cab file bug) The server OpenFire is running on is a Windows 2003 server. OpenFire is pulling user and group info out of Active Dirrectory via the LDAP protocal.

Any help would be greatly appriciated.

Hi rob

In my experience the bring window to front option has done just that, brings the window to the front and makes it active, not flash the taskbar.?

Also, are you sharing the groups in openfire? or are you just relying on the default behaviour of people in the same groups being able see each other? ie. if everyone is in group a they can see each other? I’m also thinking (out loud), that maybe these 2 people are in another group together and it could be somehow causing some problem?

To the first issue, for whatever reason, restarting the Openfire service on the server fixed the problem with those two users not recieving their contact lists. So that’s all fixed up.

As to the second, on most of the computers, checking the “Bring to front” option does exactly that. However, on two of the computers here, and I’m not exactly sure what’s special about them, checking that option instead causes the spark task bar item to flash which is what would be preferable to our users here. What else is wierd, is on one computer which I manually updated to Spark 2.5.6 for testing, instead of bringing the window to the front, or making the task bar item flash, it just causes the task bar item to turn solid orange. Go figure… ?:expressionless: If I get a chance today, I’ll check the versions of Java on several of the machines to see if it could be something with that.

Hmm thats very interesting Rob, it seems you may be running down the right track with regards to java versions as it could deffinately explain the weird issues.

I have the same problem, I receive pop-up notification, but no taskbar flash or window to front behaviour using 2.5.5 with Java 1.6.0_02, but Spark was installd AFTER this with the JRE included.

From what I’ve been able to figure out, here’s the settings needed to make the task bar item flash when you get a new message. This works on my systems here, but I can’t guarantee it works on everyone’s.

Under the Spark Prefrences menu,

Chat window : Chat tabs appear on top needs to be checked.

Appearance window: Use system look and feel needs to be checked.

Notification window: Bring window to front needs to be unchecked.

Incase that doesn’t work for you, try turning off everything in the Notifications window.

Hope this helps someone out.

One last thing I’ve noticed that causes this not to work. If your running spark under a limited user account, ie not a local admin and it’s still not flashing, do this:

Close spark.

Go into the Documents and settings<username> folder, and delete or rename the spark folder.

Run spark once as an administrator on that machineby right clicking the icon and choosing “Run As” then log on to any Openfire account.

Close spark, and run it again as the regular user, then set your preferences back up.

Roblaw80 wrote:

Under the Spark Prefrences menu,

Chat window : Chat tabs appear on top needs to be checked.

Appearance window: Use system look and feel needs to be checked.

Notification window: Bring window to front needs to be unchecked.

Incase that doesn’t work for you, try turning off everything in the Notifications window.

to me taskbar flashing always worked and works no matter what settings are