powered by Jive Software

Spark on Linux issue

I’'ve been seeing an issue trying to run Spark on my Linux box. I am using Fedora Core 6, Gnome with Compiz enabled, and Spark 2.5. The application will launch, authentication will process, but as soon as it tries to bring up the primary screen, it comes back with the error:

Error: Couldn’'t find per display information

I’‘ve tried messing with the $DISPLAY variable with no luck. I’'ve tried bringing it up using the twm window manager with no luck. Does anyone have an idea what may be causing this?

I think I’'ve found a possible culprit … http://www.igniterealtime.org/forum/click.jspa?searchID=-1&messageID=138642

The issue is identified in that thread, but no solution is given…

This seems to be caused by Java 1.6, if you still have 1.5 installed you can get around this by doing the following:

Edit the Spark script and change the line:

#INSTALL4J_JAVA_HOME_OVERRIDE=

to

INSTALL4J_JAVA_HOME_OVERRIDE=/usr/lib/jvm/java-1.5.0-sun/

(substitute with your path to the 1.5 java home, this is mine from Ubuntu 6.10 install)

Run from a terminal window to test it.

-Jeremy

Thanks!

Spark is behaving better now…but it’‘s still not quite there. Now the application will continue to run, but after authentication I have a blank window other than the Window bar at the top with the Spark icon. I’‘m using JRE 1.5.11 now. I’'ll try rolling back the Java version a little further and see what happens.

Yeah I don’‘t think rolling back the version is going to matter, 1.5 did get me the same thing you got. Actually going that route at least I can be connected; but I can’‘t see any messages from my roster list. Sadly I wanted to use pidgin instead but it’‘s not a recommended client and I’'m repeatedly booted off with the following message

“You are using an invalid client, and therefore will be disconnected. Please ask your system administrator for client choices.”

Have you tried removing the Spark & .Spark directories and reinstalling from scratch?

I’'m using 2.5.0 without any issues as described above.

Still have the same problem. Can’‘t see anything on my roster lister, can’'t see anything at all actually.

I have exactly the same issue with Spark 2.5.1 on Ubuntu AMD64.

Interesting thing is that older (2.0.8) version of spark works.

Tried Java 1.5 and 1.6.

Tried deleting .Spark directory in Home…

Get a blank screen after logging in.

Java info…

java version “1.5.0_11”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)

Java HotSpot™ 64-Bit Server VM (build 1.5.0_11-b03, mixed mode)

Message was edited by: protenus

I can report that I am seeing the same issues. I tried Spark 2.5.1 and 2.5.2 beta. Both of these have the problem that after login the any of the windows are blank. If you do a mouseover on a user their info will appear in a pop-up box but the main screen is still blank. Also if you click a user to try and send a message that window is also blank. I do not have this problem with Spark 2.0.8.

I am using SimplyMEPIS 6.5 32Bit

java -version

java version “1.5.0_08”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)

Java HotSpot™ Client VM (build 1.5.0_08-b03, mixed mode, sharing)

There is a workaround to run it with java 1.6. You will need to update the jdic.jar with the latest version available in https://jdic.dev.java.net/servlets/ProjectDocumentList?expandFolder=4183&folderI D=5497.

Regards,

Francisco

I had the same problem with AMD 64 on Ubuntu. See http://www.igniterealtime.org/forum/thread.jspa?messageID=142875 for a solution.

Yeah, well I did download that zip file, uncompressed it into the lib/linux directory, and it does log in afterwards, but I get a blank roster window. I tried with two different versions of jdic with no luck. What can be done? btw this happens with svn, 2.5.2 beta1 and 2.5.1. Also, I tried with both sun-java 6 and sun-java5. I don’'t know what to do!

This is on an ubuntu feisty linux distribution.


sorry, this has to do with bery/compiz, as if I turn off beryl I can see the window.

delete this post if you want to

Message was edited by: johnnyboy

Message was edited by: johnnyboy

I can also confirm, after downloading those binaries, and replacing mine with them, then turning off beryl/compiz, 2.5.1 is now working…

Should this be reported as an official bug?

Great !

It is reported here: http://www.igniterealtime.org/issues/browse/SPARK-734

Thanks,

Francisco