Spark Search Service no longer works in 2.5.8

The spark search service appears to no longer work in 2.5.8.

When attemting this it displays a message that says unable to contact search service.

This is an important feature and I’d like to know if there is anyway to fix this in the current release 2.5.8 or if this will be fixed in 2.5.9.

I am running spark 2.5.8 and search service works fin for me. I would check the server for errors.

I’m getting the same with a brand new install.

Spark’s Client log shows:::

SEVERE: Unable to load search services.


That’s where I’m starting …

Ok got my search working, it would seem a ‘typo’ in the server name was the culprit…


How did you resolve it? Is there a file in the spark folder that you had to modify?

I use the search feature a lot and might go back to an earlier version since the search worked but really like the new features in 2.5.8 so would like to avoid going back to an earlier version.

We still run an older wilfire server so maybe in 2.5.8 it has issues with the older wildfire servers


I had a the short version of my server name, once I put the FQDN into the server properties, then restarted the service, it just started working.

There was another thread working on this but with LDAP. Not sure there is a connection but you might want to check it out.


I’m not my system admins are planning on upgrading the server from wildfire.

Is there anyway to check against older wildfire servers and make the search feature work in spark 2.5.8 or 2.5.9 possibly.

I never realized how much I missed the feature until it no longer worked. I’m sure htis has something to do with the conference search option.

I would think that spark should detect the server version and use the old methods if the server version is older etc.


Search works fine on my system which is Openfire 3.4.1 and Spark 2.5.8. If it is not working for you then I suggest there is an error specific to your configuration.

FQDN did not resolve my search issue. I have four different PCs: two are using Spark 2.5.7 and two are using 2.5.8. The 2.5.8 clients cannot use search but the 2.5.7 clients can. We are connecting to an older Wildfire server; I’m unsure of the version. I’ll ask about updating it, but it’s unlikely with as many clients as we have connecting. I guess my only option is to downgrade my client to 2.5.7.

I’d check your search ver on the plugin page.

I have Openfire 3.4.2 and installed the latest search ver 1.4.1 and it stopped working - same error you get.

I downgraded to search 1.4.0 and it started working again.

Search Plugin version 1.4.1 doesn´t work with Openfire 3.3.3 version. In Openfire 3.4.1 it´s seems to work but with some bugs.

I recommend to downgrade the Search version to 1.4.0 and try. For more information about Search Plugin 1.4.1 problems and get the 1.4.0 version file, please read:

We upgraded to Openfire 3.4.4 recently and the search service works again.

I’m not sure which search service we have installed since I’m not one of the admins but the spark search did work after we moved over to openfire 3.4.4 server.

From what I understand the server was started from a fresh install of Openfire 3.4.4 so I assume we are using the search plugin included in that package.

With wildfire 3.1.1 and spark 2.5.8 no longer works.

I used spark 2.5.6

Works okay here with Spark 2.5.8 and OpenFire 3.5.2, once you put in the FQDN at login.