powered by Jive Software

Spark setup / 2008R2 SQL connection string

I have issues connecting to my SQL server.

Spark Server : Spark / 2008R2 OS

SQL: Spark SQL / SQL 2008R2 on a 2008R2 OS

Name of db is ChatDB.

I have set the port to be static and tried both of the following with no luck:

jdbc:jtds:sqlserver://sparksql:1433/chatdb;appName=jive

jdbc:jtds:sqlserver://sparksql\chat/chatdb;appName=jive

What am I doing wrong. I can connect to the DB from SQL manager on a different computer.

Thanks!

-Josh

you have to set your sql instance port from dynamic to something static. If its the only instance on the server, than you can use the default port of 1433. If its not the only sql instance, than you may want to use something else, like 2433.

then your connector setting should go like this. notice the (:slight_smile: after the port number!! very important!

jdbc:jtds:sqlserver://SERVER_NAME:PORT#:/INSTANCE_NAME;appName=DATABASE_NAME

heres mine

jdbc:jtds:sqlserver://server1:2433:/sqlexpress;appName=openfire