Spark showing incorrect time

Hey folks,

Some workstations here are showing incorrect time in chat window when sending/receiving any message to other users.

Some workstations are ok with time, but others have 1h difference.

Where can i see who’s sending incorret time? The server is apparetnly correct, and workstations too.

I have wildfire 3.1.1 (old, but functional…ill change do 3.4.5 in a few weeks) and Spark 2.5.7 here in my ambient.

I appreciate any help.

Thanks in advance.


Sorry, this is not a fix.

We get the same issue with Openfire 3.5.0 RC1, Spark 2.5.7 or 2.5.8, running in MojoPac Free 1.8. The system time is correct, the server time is correct, but Spark’s timestamps are behind by 1 hour.

Other than that, Openfire and Spark work beautifully.


Hi Gean,

one can set the correct time zone manually when using exe installer, not with MSI. See Spark Timezone Settings.


I think i have a problem, because i distribute a custom spark install (MSI) through GPO.

Theres no way to set time in this case?

Thanks for ur attention.


Hi Gean,

there’s none I’m aware of if you want to use the MSI installed Spark.exe.

If it’s possible for you to maintain and distribute your own files you may want to take a look at Spark.cmd start script. There you can set the parameters without issues.