powered by Jive Software

Spark stopped working on all workstations

Hi;

over the weekend spark stopped working on all of our wokrstations. It works on the server where openfire is installed but when you double-click spark on any workstations you see the icon for a second and then it vanishes. Here is the error log:

An unexpected error has been detected by Java Runtime Environment:

Internal Error (4F533F57494E13120E435050017B), pid=2124, tid=3960

Java VM: Java HotSpot™ Client VM (1.6.0_01-b06 mixed mode)

If you would like to submit a bug report, please visit:

http://java.sun.com/webapps/bugreport/crash.jsp

--------------- T H R E A D ---------------

Current thread (0x00b36400): JavaThread “Unknown thread” [_thread_in_vm]

Stack: [0x00030000,0x00130000)
[error occurred during error reporting, step 110, id 0xc0000005]

Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [kernel32.dll+0x438fa]

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
0x0ae1c000 JavaThread “Image Fetcher 3” daemon [_thread_blocked, id=2384]
0x0b9cec00 JavaThread “AWT-EventQueue-0” [_thread_in_Java, id=2300]
0x0b9cf400 JavaThread “cleanerThread” daemon [_thread_blocked, id=524]
0x0b96e000 JavaThread “AWT-Windows” daemon [_thread_in_native, id=604]
0x0b808800 JavaThread “AWT-Shutdown” [_thread_blocked, id=504]
0x0b96d800 JavaThread “Java2D Disposer” daemon [_thread_blocked, id=2296]
0x0ae2b800 JavaThread “Low Memory Detector” daemon [_thread_blocked, id=1552]
0x0ae26c00 JavaThread “CompilerThread0” daemon [_thread_in_native, id=1548]
0x0ae25800 JavaThread “Attach Listener” daemon [_thread_blocked, id=1364]
0x0ae24800 JavaThread “Signal Dispatcher” daemon [_thread_blocked, id=1144]
0x0ae13800 JavaThread “Finalizer” daemon [_thread_blocked, id=132]
0x0ae12800 JavaThread “Reference Handler” daemon [_thread_blocked, id=1352]

Other Threads:
0x0ae0f800 VMThread [id=1348]
0x0ae2d000 WatcherThread [id=2272]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None

Heap
def new generation total 960K, used 469K [0x02d00000, 0x02e00000, 0x031e0000)
eden space 896K, 45% used [0x02d00000, 0x02d666b8, 0x02de0000)
from space 64K, 93% used [0x02df0000, 0x02dfeee0, 0x02e00000)
to space 64K, 0% used [0x02de0000, 0x02de0000, 0x02df0000)
tenured generation total 4096K, used 2317K [0x031e0000, 0x035e0000, 0x06d00000)
the space 4096K, 56% used [0x031e0000, 0x03423480, 0x03423600, 0x035e0000)
compacting perm gen total 12288K, used 10750K [0x06d00000, 0x07900000, 0x0ad00000)
the space 12288K, 87% used [0x06d00000, 0x0777fb70, 0x0777fc00, 0x07900000)
No shared spaces configured.

Dynamic libraries:
0x00400000 - 0x0041a000 C:\Program Files\Spark\Spark.exe
0x7c900000 - 0x7c9b2000 C:\WINDOWS\system32\ntdll.dll
0x7c800000 - 0x7c8f6000 C:\WINDOWS\system32\kernel32.dll
0x7e410000 - 0x7e4a1000 C:\WINDOWS\system32\USER32.dll
0x77f10000 - 0x77f59000 C:\WINDOWS\system32\GDI32.dll
0x77dd0000 - 0x77e6b000 C:\WINDOWS\system32\ADVAPI32.dll
0x77e70000 - 0x77f02000 C:\WINDOWS\system32\RPCRT4.dll
0x77fe0000 - 0x77ff1000 C:\WINDOWS\system32\Secur32.dll
0x7c9c0000 - 0x7d1d7000 C:\WINDOWS\system32\SHELL32.dll
0x77c10000 - 0x77c68000 C:\WINDOWS\system32\msvcrt.dll
0x77f60000 - 0x77fd6000 C:\WINDOWS\system32\SHLWAPI.dll
0x774e0000 - 0x7761d000 C:\WINDOWS\system32\ole32.dll
0x77120000 - 0x771ab000 C:\WINDOWS\system32\OLEAUT32.dll
0x773d0000 - 0x774d3000 C:\WINDOWS\WinSxS\X86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.26 00.5512_x-ww_35d4ce83\COMCTL32.dll
0x10000000 - 0x10021000 C:\WINDOWS\system32\privman32.dll
0x5ad70000 - 0x5ada8000 C:\WINDOWS\system32\uxtheme.dll
0x74720000 - 0x7476c000 C:\WINDOWS\system32\MSCTF.dll
0x65780000 - 0x657b1000 C:\Program Files\Alwil Software\Avast4\AvJsctNs.dll
0x003f0000 - 0x003fe000 C:\Program Files\RealVNC\VNC4\wm_hooks.dll
0x77920000 - 0x77a13000 C:\WINDOWS\system32\SETUPAPI.dll
0x6d7c0000 - 0x6da07000 C:\Program Files\Spark\jre\bin\client\jvm.dll
0x76b40000 - 0x76b6d000 C:\WINDOWS\system32\WINMM.dll
0x7c340000 - 0x7c396000 C:\WINDOWS\system32\MSVCR71.dll
0x6d310000 - 0x6d318000 C:\Program Files\Spark\jre\bin\hpi.dll
0x76bf0000 - 0x76bfb000 C:\WINDOWS\system32\PSAPI.DLL
0x6d770000 - 0x6d77c000 C:\Program Files\Spark\jre\bin\verify.dll
0x6d3b0000 - 0x6d3cf000 C:\Program Files\Spark\jre\bin\java.dll
0x6d7b0000 - 0x6d7bf000 C:\Program Files\Spark\jre\bin\zip.dll
0x6d000000 - 0x6d1c3000 C:\Program Files\Spark\jre\bin\awt.dll
0x73000000 - 0x73026000 C:\WINDOWS\system32\WINSPOOL.DRV
0x76390000 - 0x763ad000 C:\WINDOWS\system32\IMM32.dll
0x73760000 - 0x737ab000 C:\WINDOWS\system32\ddraw.dll
0x73bc0000 - 0x73bc6000 C:\WINDOWS\system32\DCIMAN32.dll
0x6d2b0000 - 0x6d303000 C:\Program Files\Spark\jre\bin\fontmanager.dll
0x6d570000 - 0x6d583000 C:\Program Files\Spark\jre\bin\net.dll
0x71ab0000 - 0x71ac7000 C:\WINDOWS\system32\WS2_32.dll
0x71aa0000 - 0x71aa8000 C:\WINDOWS\system32\WS2HELP.dll
0x6d590000 - 0x6d599000 C:\Program Files\Spark\jre\bin\nio.dll

VM Arguments:
jvm_args: -Dappdir=C:\Program Files\Spark
java_command:
Launcher Type: generic

Environment Variables:
PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Common Files\Autodesk Shared;C:\Program Files\Spark\jre\bin
USERNAME=YTTech
OS=Windows_NT
PROCESSOR_IDENTIFIER=x86 Family 15 Model 4 Stepping 3, GenuineIntel

--------------- S Y S T E M ---------------

OS: Windows XP Build 2600 Service Pack 3

CPU:total 4 family 15, cmov, cx8, fxsr, mmx, sse, sse2, ht

Memory: 4k page, physical 2097151k(2097151k free), swap 4194303k(4194303k free)

vm_info: Java HotSpot™ Client VM (1.6.0_01-b06) for windows-x86, built on Mar 14 2007 00:24:02 by “java_re” with unknown MS VC++:1310

i have completed uninstalled, deleted spark directory in program files and user settings and rebooted and reinstalled the MSI on my test workstation and still have the same issue. Also updated JRE on workstation to the latest. I tried searching the forums but could not find anything that resembled my issue.

Did you install something on those machines? I mean…MS Patches or updates? Try to restore the SO to a date when it

worked fine or try to replace java, use jre-6u17 which works fine. Check if users are local admins or have enough privilegies

to run java apps. Just ideas…

i have found the solution to my problem. We use a program called privilege manager by beyond trust to allow programs that need admin rights to run correclty without the users being admins on their workstations. We updated it over the weekend and it seems to have caused the issue. We have updated it many times before and had no issues with it and it is a great program. I also didn’t think it was the issue this time as i was actually logged on to a workstation as the domain admin when trying to fix this issue so there should ahve been no privilege issues. However, Privilege Manager seemed to have an issue as it was doing the opposite of what it was supposed to be doing with the spark executable. It seemed to be sepcifically preventing the spark executable from running instead of allowing it to run. Manually uninstalling and reinstalling privilege manager fixed the problem. I am going to report the issue to the manufacturer as it took some troubleshooting to figure out the issue