powered by Jive Software

Spark - time in conversation window

Where does Spark and Wildfire get the time from ?

Now that Western Australia has daylight saving our time is one hour forward from the timezone (+8)

I have tried setting the wildfire timezone to +9, but the spark clients are still 1 hour behind.

The time on the PC’'s (windows XP) and the server (windows 2003) is correct and both have had

Microsoft patches applied to take into account daylight saving.

Any ideas.???

It seems that Wildfire and Spark are not getting the time from the OS.

thks.

(I think this might be a JAVA patch, but I don’'t know about recompiling JAVA )

I agree. My time is off by 5 hours. It does not seem to be taking my time zone into account since I am in EST (-5).

The time in Wildfire is set in the configuration. If you’‘re able to get to the management interface, the option is under Server Manager > Language and Time. If Spark isn’‘t pulling the time from the local system, I would assume that it’'s pulling the time from the server…but you know what assuming does…

I would tend to agree that it may be a Java type issue. From my experience with Operating Systems, it might lie in the way that java retrieves the time from the Operating System. I’‘m sure you’'ve already done this, but if not, you might check that both the server and client are set to the right time and timezone. Sometimes when I have experienced a time synchronization issue with other applications, a reboot of the server and clients resolves the issue.

Message was edited by: nghill

I am having an issue with the message time is 5 hours ahead of the clock. I upgraded to Vista Business and since then the all messages show 5 hours ahead only on my machine. I checked a client that has not been upgraded and the time shows right. Anyone have a fix for this issue yet?

I am having the same problem, on Vista Business. Wildfire (2003 Small Business) and every other Spark user on this network (I’‘m the only Vista machine, everyone else is XP) report correct times, but mine are six hours ahead. I’'m CST, which is -6.

Seems like for whatever reason Spark on Vista is reading the time zone incorrectly. My system is set correctly, and system clock right now reads 10:57 AM. When I message someone it comes up 4:57 PM.

Seems that the time zone is not being applied to just the conversations. I am running the 2.0.8 with the start time is right at top but the conversation time is +5 hours.

I am eastern -5 hours.

Same problem I am having (mentioned above). Didn’'t realize its a Vista issue. Just did some testing and same machine time is fine with Ubuntu and XP but not Vista.

I have one user that has upgraded to Vista that is having the same problem. He’‘s using Spark 2.0.5. Time stamps in the conversation window are +6 hours (timezone here is GMT-6) so it looks like the timezone isn’'t being properly applied. This is somewhat of a problem and is only going to get worse as more machines are upgraded to Vista.

I am having this same issue with one of our users. They are +5 hours ahead of EST. No ther user appears to be having this problem.

This is on an XP machine.

Hi,

you should be able to modify the timezone by creating a Spark.vmoptions file with the content “-Duser.timezone=Canada/Mountain” or “-Duser.timezone=GMT-8:00” or a similar one which matches your time zone. The file must be in the same directory as Spark.exe and it must be a “VMOPTIONS-File” and not a “Textfile”, some editors append “.txt” and then the file will be ignored by Spark.

LG

I am experiencing a similar problem using Spark under Linux. In the debug window, under connection information, it shows the creation time 8 hours off, as are all messages to/from me from my perspective. It appears to be ignoring the system timezone and is the only application which appears to be doing this. Spark seems to be preceiving me as being GMT whereas I am GMT-8 (GMT~UTC). I am going to try the vmoptions method to see if that resolves it.

Cheers, RioGD

Excellent, that has resolved the problem. There are some things to note, which were already noted by LG but I ran into anyway.

  • progname is case sensitive so the case LG mentioned (Spark.vmoptions) needs to be respected. (Unlike spark.properties which is all lower case)

  • Even though Spark seems to store and read its settings from ~/Spark regardless of where it itself is located and being run from, the Spark.vmoptions does indeed need to be in the appdir.

Thanks LG!

RioGD

Thanks LG, worked like a charm.

BigDog

Hey LG,

I tried the Spark.vmoptions fix listed here but it doesn’'t seem to want to take effect. I have followed the directions very carefully and have triple checked everything but it still does not seem to work. The one user that is experiencing the issue is running Spark 2.0.8 (the same as all the other users), on Windows XP.

Any suggestions as to where to look?

Thanks!

Make sure that the file is read, you can do this by adding these two new lines to it:

-XX:+PrintGCDetails

-Xloggc:c:/tmp/spark.gc.log

After starting Spark the file /tmp/spark.gc.log should be created with some more or less useful JVM memory statements. If this is not the case then your Spark.vmoptions file is either a text file or located in the wrong directory or it’'s not readable or ???.

LG

Thanks for the reply!

Unfortunately that did not work either, and no log file was created. I can guarantee the file is correct and in the right directory because I tried it on my machine and it worked like a charm - then I copied it to the machine in question and it will not work. We have tried uninstalling, deleting all spark common files in the shared directories, re-installing, etc but no go. Maybe there is something in the registry messing it up - not sure.

I’‘ll do some snooping around and if I can figure out what it might be, I’'ll post the answer.

Thanks again!

Okay, I have tried every possible way to create the “Spark.vmoptions” file with no luck.

Could someone cut-n-paste their file so I can see exactly how it is formatted? I have tried with the " (quotes) without the quotes. I have tried using the same exact time zone as the server "en / Pacific Standard Time (-8 GMT) " - I have tried "a simple, -Duser.timezone=GMT-8:00, you name it I have tried it, and yet the Spark.vmoptions file doesn’'t seem to fix the time stamp problem.

This issue is definitely related to Windows Vista, as none of my staff using Windows XP or 2000 has had a problem.

Current Server: Openfire 3.31, Current client: Spark 2.5.3

OS: Vista Ultimate 64-bit

I have asked Jive for help on this also, but haven’'t heard anything yet.

Any help will be greatly appreciated.

Regards,

Jim

Crazy question, but are you using the exe file with JDK 1.6? This had important date fixes in it.

Cheers,

Derek

We use a skinned version of the Spark client. I am not sure what JDK comes with it. Forgive the ignorance but can I just install the JDK 1.6?

okay well since I didn’‘t get a reply here I tried installing the lastest JDK from Sun’'s website and although it fixed a number of date/time problems with other Java-enabled programs it did not fix the one with Spark. My Spark client still shows UTC/GMT instead of local time, in my case Pacific DST.

This is obviously an issue with the JRE. The above recommendation may work, but until I get a definitive answer on how to create a Spark.vmoptions file in Windows I am not sure if I am doing it correctly.

Message was edited by: axcess_internet