powered by Jive Software

Spark users not in perfect alphabetical order

Using the latest version of Spark (2.63) and Openfire (3.81). Noticing on occasion 1-2 users are not in alphabetical order. And it changes from day to day who it is. Today happens to be Jeff Broadhead. Any one have any ideas? See attached.

I’m using the latest builds of 2.7.0 for quite some time (a year maybe) and i haven’t noticed such issue, though i haven’t been looking for this (using search all the time). Maybe it was somehow fixed in the latest version or your issue is specific to your setup.

Upgraded to OpenFire 3.8.2 yesterday and haven’t seen the issue since. Keeping fingers crossed maybe it was a bug with 3.8.1. Didn’t see anything in the changelogs regarding this.

I am getting the something very similar. I am on Openfire 3.8.2, and Spark 2.6.3.

After awhile, maybe with users going away and back online, they end up on the bottom of the list. Sometimes a user has two entries, one in the correct order, and one at the bottom of the list. Sometimes only one of the entries will work. And sometimes when a contact signs off, they still show on the list, as online.

I can logout and login and correct the order for a little while.

Try changing you reconnection option to Display in contact group in the Preferences > Appearance. At least in the latest Spark builds this option removes issues with doubled offline contacts after your Spark reconnects after the network connection loss, etc.

So far everything still looks alphabetical. But right now Spark says 13 online, and on Openfire there are 19 sessions. I also see 8 contacts as online, although on server only 4 are online, one includes me.

Any other tips or suggestions?

Left Spark connected over night, and now the list is out of alphabetical order, when I check offline users there are duplicates there as well as the online/away contacts. The users who show online or away who are really not show as offline when I initiate a message. But the contact list does not update their status.

I do see Client Connections Settings in Openfire under Server settings, which is not on our old Openfire server. But I am unsure if changing any of the default settings will have any affect.

I am thinking there is something on the Openfire config that needs attention, not Spark itself. Because everything was working perfect on Openfire 3.5.2.

OK, I disabled the Idle Connections Policy settings under Client Connections and over night my contact list has the correct number of users and they are alphabetical. Only thing is that there are some duplicates in the offline group.

I also restarted the Openfire service on the server. Not sure if the restart helped things, or the Idle Connections Policy fixed things. I will keep this updated as needed.

modulok wrote:

Only thing is that there are some duplicates in the offline group.

Have you changed the reconnection option as i have suggested?

Of course!

Edit: Well still no luck. The online count is still correct, but I see ‘online’ contacts who are in fact not logged on at all. I may try a different client just to see if its isolated to Spark. I don’t understand why it’s doing this with the updated Openfire server.

I had some cache issues in the warning logs, I increased caches for roster, user, and vcard. warnings went away, but still having some issues with accurate contact lists.

org.jivesoftware.openfire.net.SocketReader - Closing session due to incorrect hostname in stream header.

Host: spark. Connection: org.jivesoftware.openfire.net.SocketConnection@16ad8e7 socket: Socket[addr=/127.0.0.1,port=38588,localport=5269] session: null

Servername is openfire, but in my DNS server I use an alias for ‘spark’ pointing to ‘openfire’ server. This is how it was setup with my old openfire server.

Could that be part of the issue with incorrect on/offline contacts, duplicating, and wrong alpha order?

Well, i can’t say if that could be the cause, but i have never used Openfire with one hostname and clients pointing to another servername. It could cause problems potentially. You should do in Spark: enter your server’s hostname as a servername and then in Advanced settings uncheck Automatically discover and put DNS alias as a host. I was doing this way when i didn’t had DNS name and was using IP address as a host, now i use the same thing in my virtual machines with Spark running in them.

I see some of the same errors with the real dns name of the server, not the alias.

I am debating running an older version of Openfire now. This inconsistant contact list is becoming a real pain. Anything else I can check?