powered by Jive Software

Spark voice chat can not talk in defferent LAN

HI ,i found a question :when two sparks talk from LAN to LAN,voice chat can not work!!! why?

Message was edited by: lidongyugood

Were any error logs produced? if so, putting them up may help answer your question

Hi i use openfire 3.3.0 as my server,and set stun server in my local server.Two spark can talk in LAN,but can not talk from LAN to LAN.

Are they on the same domain?

yes there are in same domain

In Spark you can use the debug window to see what information was sent/recieved. Have you tried seeing if anything was displayed in your debug window.

Can you describe your netowrk scenario?

Do you have any firewall between two points?

Can you check if the router blocks UDP traffic?

Hi,i have two spark .there are in different LAN.The firewalls of them are closed,and i set stun server and media proxy in my local openfire server .my openfire server in public Interne.

Can everyone check your <spark folder>/logs/error.log. After you fail to voice chat, do you have this kind of error ?

Exception on commit = java.io.IOException: Can’t find registry file

Exception on commit = java.io.IOException: Can’t find registry file

0

BS:gsm

java.lang.NullPointerException

Track 0 is set to transmit as:

gsm/rtp, 8000.0 Hz, Mono, FrameSize=264 bits

javax.media.rtp.InvalidSessionAddressException: Local Data AddressDoes not belong to any of this hosts local interfaces

at com.sun.media.rtp.RTPSessionMgr.initialize(RTPSessionMgr.java:2664)

at com.sun.media.rtp.RTPSessionMgr.initialize(RTPSessionMgr.java:2515)

at org.jivesoftware.smackx.jingle.mediaimpl.jmf.AudioChannel.createTransmitter(Aud ioChannel.java:372)

at org.jivesoftware.smackx.jingle.mediaimpl.jmf.AudioChannel.start(AudioChannel.ja va:129)

at org.jivesoftware.smackx.jingle.mediaimpl.jmf.AudioMediaSession.startTrasmit(Aud ioMediaSession.java:92)

at org.jivesoftware.smackx.jingle.JingleSession.triggerSessionEstablished(JingleSe ssion.java:1090)

at org.jivesoftware.smackx.jingle.OutgoingJingleSession$Active.eventEnter(Outgoing JingleSession.java:438)

at org.jivesoftware.smackx.jingle.JingleNegotiator.setState(JingleNegotiator.java: 137)

at org.jivesoftware.smackx.jingle.JingleSession.setState(JingleSession.java:327)

at org.jivesoftware.smackx.jingle.OutgoingJingleSession$Pending.eventAck(OutgoingJ ingleSession.java:379)

at org.jivesoftware.smackx.jingle.JingleSession.dispatchIncomingPacket(JingleSessi on.java:415)

at org.jivesoftware.smackx.jingle.JingleSession.respond(JingleSession.java:484)

at org.jivesoftware.smackx.jingle.JingleSession$2.processPacket(JingleSession.java :912)

at org.jivesoftware.smack.PacketReader$ListenerWrapper.notifyListener(PacketReader .java:819)

at org.jivesoftware.smack.PacketReader$ListenerNotification.run(PacketReader.java: 799)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

at java.util.concurrent.FutureTask.run(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

anyway, i have 2 ip in my pc, already test by switching off one of them, but seems like i’m getting the same error.

Mohaja,

Which OS are you using?

javax.media.rtp.InvalidSessionAddressException: Local Data AddressDoes not belong to any of this hosts local interfaces

Hi,

i’m using Windows XP sp2, 512MB ram. Currently not using windows firewall, just nod32; already tried turning of the nod32’s internet monitor but to no success. Already check the services with my other pc that works but its all the same. By the way, i am testing openfire & spark with my colleagues. Most of them able to do the voice chat but few of them can’t meaning we can dial or recieve a dial but when the recieving party click accept it will just saying establishing connecting and will just timeout saying no media detected. Hope this will help. thanks.

Hi ,my server is window xp,and set media proxy and stun server in my localhost.There are Logs of two clients.sparkA:172.19.9.109sparkB172.19.209.239 Server Ip :202.115.143.85

outgoingcall:

Initialized

1

1

Initializing…Resolved

Listening for ECHO: 172.19.9.109:14806

C: /172.19.9.109|/172.19.9.109 p:2195

Service listing

Initializing…Resolved

UpdatePacketListener

Jingle: <iq id=“HX7n7-8” to="bb$scm.net.cn@202.115.143.185/Smack" from="ll@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="bb$scm.net.cn@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“transport-info” sid=“5934709060446387553”><content name=‘Audio-Content’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“172.19.209.239” port=“17622” network=“0” username=“1” password=“6523048689249463005” preference=“2195” type=“prflx”/></transport></content></jingle></iq>

0

Jingle: <iq id=“HX7n7-9” to="bb$scm.net.cn@202.115.143.185/Smack" from="ll@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="bb$scm.net.cn@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“transport-info” sid=“5934709060446387553”><content name=‘Audio-Content’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“202.115.143.185” port=“13226” network=“0” username=“1” password=“7089622262738632148” preference=“0” type=“relay”/></transport></content></jingle></iq>

Jingle: <iq id=“HX7n7-7” to="bb$scm.net.cn@202.115.143.185/Smack" from="ll@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="bb$scm.net.cn@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“description-info” sid=“5934709060446387553”><content name=‘Audio-Content’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /><payload-type id=“4” name=“g723” channels=“1” clockrate=“0” /><payload-type id=“0” name=“PCMU” channels=“1” clockrate=“16000” /></description></content></jingle></iq>

Jingle: <iq id=“HX7n7-10” to="bb$scm.net.cn@202.115.143.185/Smack" from="ll@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="bb$scm.net.cn@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“content-accept” sid=“5934709060446387553”><content name=‘Audio-Content’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /></description></content></jingle></iq>

BS:gsm

1

2

3

4

5

6

7

8

9

ADDED Valid Cand: 202.115.143.185:13226

Relay Type

Relay Type

Jingle: <iq id=“HX7n7-11” to="bb$scm.net.cn@202.115.143.185/Smack" from="ll@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="bb$scm.net.cn@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“session-accept” sid=“5934709060446387553”><content name=‘Audio-Content’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /></description><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“202.115.143.185” port=“12856” network=“0” username=“1” password=“3232088990319908255” preference=“0” type=“relay”/></transport></content></jingle></iq>

Relay Type

Jingle: <iq id=“HX7n7-13” to="bb$scm.net.cn@202.115.143.185/Smack" from="ll@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="bb$scm.net.cn@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“transport-accept” sid=“5934709060446387553”><content name=‘Audio-Content’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“202.115.143.185” port=“12856” network=“0” username=“1” password=“3232088990319908255” preference=“0” type=“relay”/></transport></content></jingle></iq>

Cand: 202.115.143.185

Relay Type

SET ACTIVE

Transport stabilished

Relay Type

triggerTransportEstablished 172.19.9.109:12856|202.115.143.185:13226

Relay Type

Relay Type

Relay Type

Relay Type

Relay Type

org.jivesoftware.smack.XMPPConnection@789144 202.115.143.185: 12030->14192

Track 0 is set to transmit as:

gsm/rtp, 8000.0 Hz, Mono, FrameSize=264 bits

Created RTP session at 12030 to: 202.115.143.185 14192

incomingcall

Initialized

1

1

Initializing…Resolved

C: /172.19.209.239|/172.19.209.239 p:2195

Listening for ECHO: 172.19.209.239:17570

Service listing

Initializing…Resolved

UpdatePacketListener

Jingle: <iq id=“H6oyy-8” to="ll@202.115.143.185/Smack" from="qq@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="qq@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“transport-info” sid=“7558319155648544293”><content name=‘Audio-Content’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“172.19.9.109” port=“11052” network=“0” username=“1” password=“7930348670553777584” preference=“2195” type=“prflx”/></transport></content></jingle></iq>

Jingle: <iq id=“H6oyy-9” to="ll@202.115.143.185/Smack" from="qq@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="qq@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“transport-info” sid=“7558319155648544293”><content name=‘Audio-Content’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“202.115.143.185” port=“18568” network=“0” username=“1” password=“7428074536771152777” preference=“0” type=“relay”/></transport></content></jingle></iq>

Jingle: <iq id=“H6oyy-10” to="ll@202.115.143.185/Smack" from="qq@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="qq@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“content-accept” sid=“7558319155648544293”><content name=‘Audio-Content’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /></description></content></jingle></iq>

0

BS:gsm

1

2

3

4

5

6

7

8

9

ADDED Valid Cand: 202.115.143.185:18568

Jingle: <iq id=“H6oyy-11” to="ll@202.115.143.185/Smack" from="qq@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="qq@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“transport-accept” sid=“7558319155648544293”><content name=‘Audio-Content’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“202.115.143.185” port=“10038” network=“0” username=“1” password=“1317316830380645295” preference=“0” type=“relay”/></transport></content></jingle></iq>

Cand: 202.115.143.185

Relay Type

SET ACTIVE

Transport stabilished

Relay Type

triggerTransportEstablished 172.19.209.239:10038|202.115.143.185:18568

Relay Type

Relay Type

Relay Type

Relay Type

Relay Type

org.jivesoftware.smack.XMPPConnection@1833955 202.115.143.185: 12114->16978

Track 0 is set to transmit as:

gsm/rtp, 8000.0 Hz, Mono, FrameSize=264 bits

Created RTP session at 12114 to: 202.115.143.185 16978

Jingle: <iq id=“H6oyy-12” to="ll@202.115.143.185/Smack" from="qq@202.115.143.185/Smack" type=“set”><jingle xmlns=“http://jabber.org/protocol/jingleinitiator="qq@202.115.143.185/Smack" responder="ll@202.115.143.185/Smack" action=“session-accept” sid=“7558319155648544293”><content name=‘Audio-Content’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /></description><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“202.115.143.185” port=“10038” network=“0” username=“1” password=“1317316830380645295” preference=“0” type=“relay”/></transport></content></jingle></iq>

Hello,

Yes, your problem is knew. As we use UDP for voice traffic, many firewalls blocks it.

Weel, what you can check is trying to disable nod32, but according to our tests nod32 don’t affects your voice, if you setup it and configure it to allow UDP traffic.

You should also check your network elements such as routers , switches and firewalls.

Best Regards,

Thiago

lidongyugood,

Your are really unable to discovery even your public IP in your machines, you can check it in your logs.

That both users are NOT sending public IP candidates. Only local Ips.

Please make sure your STUN Server is really working, or try another one STUN Servers.

My personal guess is that your problem is related with router or netowrk elements.

Please try to realize an UDP test with another applications if you want to make sure that your network setup is perfect.

Cheer,

Thiago

Hi barata7,Thanks for your help, i test my network .there is symmetric firewall in my localhost server.So may be this is reason why two spark can’t talk in differetn LAN.