powered by Jive Software

Spark Web

Hi,

I am running Openfire 3.6.1, behind a load balancer that is accessible publically, i open ports 5222, 5223, 7070. Now i want to run the web spark. after insatlling it on the same machine which has im server, when i gave user name password it gives me “wrong user name and password”, then i changed following in SparkWeb.html

SparkWeb.html

server: “192.168.0.9”, #localmachine on which the im server is running
connectionType: “http”,
port: “5222”,
autoLogin: “false”
};

This change gives me no error but no login

Then i chaneg it SparkWeb.html

return {
server: “192.168.0.9”,
connectionType: “http-bind”,
port: “5222”,
autoLogin: “false”
};

This change give the folloiwng error


2008.12.26 19:38:06 Closing session due to exception: (SOCKET, R: /192.168.72.250:54150, L: /10.10.40.9:5222, S: 0.0.0.0/0.0.0.0:5222)
org.apache.mina.filter.codec.ProtocolDecoderException: java.lang.Exception: Disallowed character (Hexdump: 3C 70 6F 6C 69 63 79 2D 66 69 6C 65 2D 72 65 71 75 65 73 74 2F 3E 00)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF ilter.java:170)
at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:299)
at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:53)
at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:648)
at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java :239)
at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(Execut orFilter.java:283)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)
at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.Exception: Disallowed character


When i access it through local lan with default settings it works. Where i am wrong ?

Thanks

Mudasar

Hi,

One more thing to mention, IM server apache is running on 81 port.

Thanks

mudasar

http://www.igniterealtime.org/community/docs/DOC-1553

Hi,

Thanks it works by using RED5, it is good plugin. But i am unable to access in through http://my.im.server:7070/red5/sparkweb/index.html

, so i copy the complete directory plugin/admin/webapp/sp/red5 and access it throuhgh url http://im.serevr:9090/sp/red5/sparkweb/index.html.

what is the defrult directory if i use 7070 port. and where are the settings to set the URI part.

One more thing i am unable to getting setting box on sparkweb red5, should i open anyother port. currently i open 5222, 5223, 5229, 5230, 7070.

Thanks.

Did you restart your server after red5 installation? If you want it to use with 9090 port when you should open 9090 port too i think. Have you enabled http-bind in Openfire settings? That maybe also a cause why 7070 is not working for you. You dont need 5229 port for now (now policyfile is going through 5230, though it may fallback to default 5229 after Openfire would be patched).