powered by Jive Software

Spark will not connect to server

I am trying to switch to Spark without success. I have Spark 2.8.2 and Openfire 4.0.4. Without “Accept All Certificates” checked I get the error “Unable to verify certificate*”*. When “Accept All Certificates” is checked but “Disable Certificate Hostname” is unchecked I get “Certificate Hostname verification failed”. With both “Unable to verify certificate” and “Accept All Certificates” is checked I get "Invalid username or password".

I have followed the troubleshooting tips here and added sasl.mechs = PLAIN . The xmpp.domain, Server Name, and SSL Certificate (Signed by StartSSL) are the same (server.domain.org), as is the host in Spark. The Openfire Identity Certificate Store shows the certificate is correct and CA Signed. I have both DNS and SRV records set up.The setup works just fine in Pidgin. I have tried 2 different servers on 2 different domains, and the same thing happens for both. One has a internal user database and the other uses AD.

To test you can try registering test account at jabber.at - Register . For me Spark can login to that server without both settings checked (Java in Spark sees their certificate as trusted).

Its a brand new installation of Spark.Does jabber.at use the latest version of Openfire?

More information. I used Wireshark to capture the packets, and it appears that the servers send the correct SSL certificate with the correct DNS name. I have no idea what Spark is seeing, but all indications is that the server is sending the server.domain.org name for both servers.

I don’t know what jabber.at uses. Most probably not Openfire. I just know that it works with Spark without Accept all certificates option. So you can test your Spark against it. Because your case is weird, it should work with Accept all certificates option enabled even if certificate is expired, self-signed and completely not trusted So there must be something else in your case. So if you can’t login to jabber.at, this will rule out the SSL issue, i think.