powered by Jive Software

Spark window changing itself when inactive

I am trying to figure out if there is a way to stop the spark windows from switching between each other depending on which window has a new message in it. I use spark in my job and generally am in at least 2 group convos and between 1 and 4 IM’s at once. I need to be able to follow the conversation in a window but if Spark is not the active window on the screen then it changes to whichever conversation has a new message posted which is bad for me when I am tryign to go through files and follow along on a convo when somone else is talking in the group chat and the window switches over on me.

I can’t reproduce this with the latest Spark version from here http://www.igniterealtime.org/downloads/nightly_spark.jsp

Thanks for the link. I downloaded the latest version in that link which is 2.7.0. The version I downloaded when I was hired by the company I am now working for was 2.5.8 and it showed no available updates so I wasn’t aware that there was a newer version as I just installed it on the 10th. I will use this new version when I go back to work and see if the issue continues on my end or not and will post back up here to let you know if this fixed it or if there is something in my windows settings (apparently) that is causing it do switch windows on me.

You can also check if Bring window to front option is not checked in your preferences (Notifications).

2.5.8 is very old and many things changed since then. So you should test 2.7.0 before switching completely. Especially if you need voice chat (in recent versions it doesn’t work ok).

Downloaded 2.7.0…still does the window shift. Bring wndow to front is disabled, I disabled all the notifications trying to identify what causes the window to change but I had no luck. Some people it does it to even while they are typing a message so I guess I should count myself lucky that it only happens to me when the chat window is inactive.

Do you have Java 6 installed on your system? It was known, that Spark will use Java 6 instead of a built-in Java 7 if it founds one on the system. and the focus stealing bug was because of the bug in Java 6. But the latest 2.7.0 versions should only use Java 7 and actually should refuse running if Java 7 is not present. So maybe that’s not the case, but worth checking. Also go to Help > About window in Spark and check which Java version is in use. Should say “JRE Version: 1.7.0_51”.