powered by Jive Software

Spark won't start unless I have administrative rights

Greetings from Portugal,

Hi!

We installed the openfire + spark at our company a few months ago, everything is working swimmingly with the exception of spark on some machines.

What happens is, after the user login in the domain, execute spark, which creates the process, however there is no visible icon at taskbar. If i kill the process, and run it with administrative privileges everything works good.

Additional details:

Domain: Windows Small Business Server 2008

Client Computers: Windows XP with SP3

Any help will be greatly appreciated, thanks in advance

there might be some problems into Java Vm access privileges.

Tanks for the response!

Can you please be more specific, I never change any configuration settings for the Java Vm access privileges for any of the client computers, nevertheless some computers work and some won’t…

Please check logs into your OS. Is there any java error or warnings ?

Hi again,

I check both application and system event, and there no entries regarding spark. Is there any configuration that enables the error messages throughput in the “windows event viewer”?

I also cleared Spark\logs directory, and execute spark, which creates an “error.log”

— Start of “error.log” —

17/Set/2010 16:48:22 org.jivesoftware.spark.util.log.Log error
SEVERE: Error unzipping plugin
java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.(Unknown Source)
at java.util.jar.JarFile.(Unknown Source)
at java.util.jar.JarFile.(Unknown Source)
at org.jivesoftware.spark.PluginManager.unzipPlugin(PluginManager.java:571)
at org.jivesoftware.spark.PluginManager.expandNewPlugins(PluginManager.java:503)
at org.jivesoftware.spark.PluginManager.loadPublicPlugins(PluginManager.java:511)
at org.jivesoftware.spark.PluginManager.loadPlugins(PluginManager.java:170)
at org.jivesoftware.spark.Workspace$4.run(Workspace.java:257)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


Hi Ricardo,

I wonder whether these users have redirected their home folder. Do you have a “%USERPROFILE%\Spark” and a “%USERPROFILE%\Spark\plugins” folder on those systems? Can the normal user write to this folder?

Can the user read the files in “%ProgramFiles%\Spark\plugins” ?

LG

I had the same issue a while back, I think it was resolved by giving each user full control NTFS permissions to the Spark directory.

Can you open the files in the plugins folder with your zip program?

Good morning
In our network we work with Roaming User Profiles, this allows for any user to log on to any computer on the same network and access their documents and have a consistent desktop experience. The roaming profiles are located in \Server\RedirectedFolders\username, in this directory “%USERPROFILE%\Spark” and a "%USERPROFILE%\Spark\plugins” both directories exist.

When I login with the specified user on Win XP SP3 computer, those directories are not present, I also check in similar configuration, and still the directories are not present, but in this case spark works well.

This is funny but in Win 7 the directories exist, but I can’t found them in Win XP.

I copied the content from “Spark” and “Spark\plugins” to the %USERPROFILE % from the server, but the problem persist.

I also set “full control” permissions to the %Program Files%\Spark, but the problem persisted, this is was my first approach… this normally works for programs which don’t make use of the Windows Registry database.

What spark version do you use ?

The last one, spark 2.5.8.

I had the same problem symptoms. Would work if run as Administrator or another user, local Admin on the computer would work as well.

Most users are set up with roaming profiles, the profile redirects to \server\users$\username

Due to a name change the username was different to the profile location

Changing the rights on \server\users$\username to full access was successful at fixing the problem.