powered by Jive Software

Sparkweb 3.4.3 login problems

Hi,

I just installed Openfire and sparkweb on a local OpenSUSE server.

Admin console works great both locally and on machines in my LAN.

Alas I can’t login to sparkweb.

None of the users I have create, including admin get access…

I read document 1553 and edited Sparkweb.html, changed my server.

All the rest is out of the box/off the shelf.

Any idea what is wrong?

What is your config (sparkweb.html)? Also, have you tried disabling the firewall on that server?

Hi,

There is no firewall running on this server.

Firewall is provided externally.

I also tried using the spark client (both on the server and local pc) and also can’t get into the system (invalid user name or password)

According to console the server name = s2w-dev

The local address is 192.168.2.20

The server has NO in house dns name.

The dns name used from the internet is s2w.dyndns.info (this can also be used from my lan)

I believe you have to login to s2w-dev from the outside as this is server’s domain name. What server name do yo uspecify when trying to login with Spark from the server and local pc? From the server doesn’t it work with ‘localhost’ or ‘s2w-dev’? From local pc what about ‘192.168.2.20’?

Hi,

Locally I tried all 3 possibilities as server name.

Which name does one use to login “admin” or “Administrator”?

I’ve been using the Username as defined through the web console and not the Name.

I will check with wireshark running later and see what I can observe at packet level.

If you want this server to be accessible from outside your network you need to configure it with a FQDN that can be resolved externally (chatserver.domain.com). This name must be the Openfire server name, the XMPP domain and the name used to generate the self signed certificates. This is the name that would go in the server field. the default admin username is admin. All client software must use the FQDN for the name of the server to properly authenticate to the server.

Hi,

Would the fact that I see little locks behind various port numbers in the Openfire Admin Console have anything to do with my problems:

Server Ports

Interface
Port
Type
Description
All addresses
5222

Client to Server
The standard port for clients to connect to the server. Connections may or may not be encrypted. You can update the security settings for this port.
All addresses
5223

Client to Server
The port used for clients to connect to the server using the old SSL method. The old SSL method is not an XMPP standard method and will be deprecated in the future. You can update the security settings for this port.
All addresses
9090

Admin Console
The port used for unsecured Admin Console access.
All addresses
9091

Admin Console
The port used for secured Admin Console access.
All addresses
7777

File Transfer Proxy
The port used for the proxy service that allows file transfers to occur between two entities on the XMPP network.
All addresses
7070

HTTP Binding
The port used for unsecured HTTP client connections.
All addresses
7443

HTTP Binding
The port used for secured HTTP client connections.
All addresses
3478 & 3479

STUN Service
The port used for the service that ensures connectivity between entities when behind a NAT.
All addresses
5229

Flash Cross Domain
Service that allows Flash clients connect to other hostnames and ports.

These locks mean that these ports are using SSL.

OK.

This may then be part of the problem.

I have not installed or configured any SSL or certificate on my server.

I will check.

Hi,

I think I found part of the problem…

This error is thrown when try to login using “Discover server and port automatically”

1067238 [SocketAcceptorIoProcessor-0.0] WARN org.apache.mina.common.support.DefaultExceptionMonitor - Unexpected exception.
org.apache.mina.common.RuntimeIOException: java.net.SocketException: Protocol not available

This problem doesn’t oocure when I disable that feature and I can then at least login as admin from a local PC.

Any idea how to solve this issue?

Where do you disable this option? In SparkWeb? Don’t remember such thing, though i didn’t use SparkWeb for a while. If you can’t connect with that option tirned on, it means that your client can’t find server by its name, DNS is not working, it doesnt know such hostname (not in its hosts file), etc.

No you change that setting in the normal Spark client.

Have not been able to find this setting in Sparkweb so there I’m still not able to connect but the same error is generated.

Hm. I checked in 2.5.8 and it was called a bit different. But the point is the same.