Sparkweb fails to login after Openfire 3.6a update

Hi all,

We’ve been using sparkweb very sucessfully for the past several months and the since updating the Openfire server it now fails to work. You login, it looks like its going to launch the app (screen changes breifly) then dumps you back to the logon prompt.

Rolled back to 3.5.2 and the Sparkweb works no problem.

Tried this on a fresh install of 3.6a - again logon fails

Tired on fresh install of 3.5.2 - works perfectly, upgrade to 3.6a and again it dumps you back to logon after authentication.

Has anybody else had this issue? If so is it common? is there a solution or is it just a matter of roll Openfire back to 3.5.2 to things stable?

Yes. You are not the only one seeing this. SparkWeb 0.9.0 has stopped working for me too. But as developers say, it’s a problem with SparkWeb, not a server. I was suggested to download newer SparkWeb.swf (igniterealtime chat is using it). But it didnt help in my case. I also tried to switch from the socket connection to http-binding. No luck. There are other threads discussing such problems. Maybe new release of SparkWeb will fix that.

Unfortunately I seem to have the most uptodate version of the web client but it still bombs out.

May have to look into other alternatives if there isnt a “fix” soonish.

Thanks for the reply.

I have the same problem I think, very well detailed here:

I’m wondering if I’m better off keeping OpenFire 3.5.2 in production, even with its limits in LDAP support…



I find it strange that many of the problems seem to stem from the SparkWebSkin.swf file missing… this isn’t even included in the newest release.

I never tried SparkWeb with anything other than 3.6.0a, so I’m sure there’s something I’m missing.

My SparkWeb.swf file is dated Sept. 11, 2008 @ 12:04.00 PM (Who works on 9/11?)

File size is 616kb.

I had the same errors everyone else reports and the only fix I found was the below config,

return {
server: “lunchbox”,
connectionType: “http”,
port: “7070”,
bindPath: “/http-bind/”,
autoLogin: “false”

One note - this ONLY works from a browser pointed to http://lunchbox

I have the sparkweb folder set as my default web site under IIS, so I don’t need to add the port or directory to my URL.

If you try to run the SparkWeb.html file from any other method, several errors crop up.

For instance, don’t try to open the file directly from the directory x:\sparkewb\sparkweb.html, it MUST be served via a web server.

Others have had sucess puting the sparkweb folder in their Openfire install at x:\openfire\plugins\admin\webapp and running it like this


I haven’t needed to try this, but it may work.

I wish I could wave my magic pocket protector and make it work for everyone. :slight_smile: