SparkWeb Open Source

Earlier today I exported our svn repository for SparkWeb and committed the intial import to the new open source repository! Instructions for getting and building the source are available. The specified item was not found… A chat room for discussion of SparkWeb development can be found at I’m looking forward to seeing what the community can do!

thankyou thankyou thankyou

Hi i wonder if there’s an opensource plugin yet to replace enterprise.jar without losing sparkweb??

Yeah, sorry. I need to get on that. Should be up pretty soon.

Daniel’s been trying to get an ant+mxmlc workflow going, but with little success so far. Hopefully someone will figure it out

To expand upon what David said. I’ve checked in the beginnings of an ant build script. I’ve had no luck what-so-ever so far getting the messenger.swf resource to be embedded, which is the current blocking point for it. (tried a number of methods, tried a number of chat rooms too lol)

So if anyone wants to check out trunk and see if they can’t figure out how to get the ant task working properly, please do. Or even, if you are capable of building SparkWeb from the command line using mxmlc, please send me the entire command you used to get it to build and I should be able to fix up the ant task appropriately!

Thank you!

How to build SparkWeb without Flex Builder ? There is an open source choice to build and develop Spark Web ?

Please read the comments mere inches above yours.

Ok.I am not an flex developer, I am a java developer and I thought that flex had another IDE, as java. Thanks.

Ok folks, this works for me.

Checkout all 4 projects and merge into a single sparkweb root folder that looks like this










where make_sparkweb.cmd contains

C:\flex30\bin\mxmlc.exe -locale=en_US -source-path=…/locale SparkWeb.mxml

Embedding messenger.swf was a real pain but all errors disappeared after I added -source-path

Hi dele,

I merged the sparkweb project as you said, but the compile command not works for me. First the compiler not works because it didn’t find some flexlib.swc components. Second because the compiler found a duplicate variable definition in

When I solved this two errors the compiler runs with some warnings, but run.

When I opened the SparkWeb.swf only showed a blue background browser. The browser didn’t load the SparkWeb, unlike the pre-built version available…

dele, you made another configuation in your enviroment ?

Hi dele! This might be a good way to go for now. We really want to not have to merge things together like that. My thoughts are that clearly flex builder can do it, why can’t we? I’m sure there’s something piddly I’m missing. Might even play with that -source-path option a bit and see if I have any luck. messenger.swf is the one thing that doesn’t want to merge in. No matter what I’ve tried with the existing structure, it seems to refuse to find messenger.swf. (sigh) I’ll implement your method in the ant build file if I fail at my next stab. =)

Have a look at the modified SparkWeb in the Red5 plugin. It will show you what worked for me. I already use flexlib.swc so it is already in the frameworsk/lib folder of flex3 on my pc.


I did a lot of googling on the Embed “messgenger.swf” error and everything came back pointing at -source-path, but I simply could not get it to work. In the end, I put SparkWebCommonComponents.swc in the framework/lib folder in order to move past that error and then got stuck with the locale error. In solving the locale error, I picked on a suggestion to re-organise folder structure and use -source-path and that cleared the locale error. I removed SparkWebCommonComponents.swc from the framework/lib folder and the embed errors were gone as well.

Hello jadestorm!

I agree with you said “If flex builder can do it, why can’t we ?”.I am working with Netbeans and based on dele post I made an ant build like this …

I will download Flex Builder and try to inspect the compiler action to get some insight.

Were you able to build it with that script? I’m not =)

dele, I’m running into the same old crap with not being able to find messenger.swf after restructuring as you suggested. =( Any suggestions? There’s one difference in that, I am building without seeing my working directory “inside” of src. (ie I’m specifying a full path to locale and such) In theory that ought to work. But it’s not. =D

I am not believing this… the bazillion messenger errors? had nothing to do with messenger.swf. Turns out it was another error triggering these errors. a red herring if you will. I’ll be committing a build file soon.

Hi jadestorm and dele,

My problem was the flash player. I was not installed it :S. So After install the flash player my SparkWeb.swf, I got the same error posted on “Getting and Building SparkWeb” ( When I opened the swf file I got the error (TypeError: Error #1009: Cannot access a property or method of a null object reference).

So dele, your command on red5.war works fine, as my build.xml. Jadestorm you will commit a new build.xml soon ? It’s working fine for you ?

Thank You !!! The Best GROUP.