powered by Jive Software

Sparkweb SSL not logging in

I am trying to get sparkweb working over ssl it I can’‘t get it to log in, it just sits there with the pinwheel of death (saw it in another post and it sounded funny). if I go to http://myserver:8080/sparkweb/ I can log in with no problems but going to https://myserver:8483/sparkweb I get the security certificate prompts and then I get the login screen and put my info in and it attempts to log me in but never goes past the pinwheel. I have tried this on multiple machines and on IE and Firefox with the same result. I am running openfire 3.3.1 with sparkweb 1.0 and I don’'t see any errors that might indicate a problem. If you need to see excerpts from my error logs let me know.

Thanks

I’'m seeing the same problem with Sparkweb 1.0.0 and Openfire 3.3.2. My server is configured to only allow secure connections. The only thing that shows up in the openfire log is “Client provided invalid session: fc20cbfe.” The server is running on windows, and the client is Firefox.

Message was edited by: aelix

I believe I have a fix for this issue. I’m just cleaning it up and testing at the moment.

I’m hoping you add the fix to the 3.3.x branch. Sparkweb is not usable without SSL support, I doubt very many enterprises would allow their employees to login cleartext, I know we don’t.