SparkWeb SSL

Has anyone ever gotten sparkweb to work with ssl? I tried every post sometime last year to no avail but now since an update has been released for openfire I have decided to revisit the issue but I still cannot get sparkweb to work with SSL.

It has a lovely interface but we can’t use it without SSL.

Have you read this document?

Few years ago i was able to make it work SSL. Not sure about Openfire 3.7.0 though.

See my blog about SparkWeb at ard

There is now a version of SparkWeb that uses the latest XIFF library and consequently supports TLS. I have not tested it, but it should work.

If you want the old style SSL on port 5223, then try the old SparkWeb for Red5

Thanks wroot but that’s the document I’ve been trying to use and it has never worked. Whenever I configure the settings I’m unable to login to sparkweb. The page is stuck after I enter username and password and click login. Since becoming a member of IgniteRealtime I noticed a “chat with” bar at the lower right corner of the support forum. What chat application is used for that?

I’ve looked at your blog re: the new sparkweb and I have downloaded and tested it but experience problems whenever I resize the browser window.

Could you please confirm

  1. Which “new” SparkWeb did you test?
  2. Did TLS work or not?


Sorry if I was vague. I tried out the Web Client from the blog here: ard

It can login but if you open a chat window then resize the browser the chat window covers the contacts list.

When I enable security in the openfire server it still logs in but on the sessions screen there is no padlock to indicate a secure connection.

I’m really interested in the sparkweb 0.9.0 it has a simple interface… We implemented the spark 2.5.8 and just want to supplement it for our web users. Something to run from our intranet but secure.

I was pointing you at this version

which was the 0.9 modified with the latest XIFF library which supports TLS

Thanks for this link. I’ve downloaded it and will try to get it to work securely. Thanks again.

I downloaded extracted it and copied the bin-debug folder to my /var/www folder.

When I browsed to the folder and clicked SparkWeb.html it came up fine although with the username and password already populated.


But I am unable to login to it. It says

“Problem authenticating with the server or you are not authorized to perform this operation.”

I’m able to login to the older version which is hosted in another folder.

Where do you think the problem lies?