Sporadic Http-bind policy-violation (?overactivity?) errors


Im receiving sporadic policy-violation errors i could only atribute to overactivity.

I found the following code in openfire, HttpSession.java:

if(overactivity) {
if (!JiveGlobals.getBooleanProperty(“xmpp.httpbind.client.requests.ignoreOveractiv ity”, false)) {
throw new HttpBindException(errorMessage, BoshBindingError.policyViolation);

I then tryed to add the property **xmpp.httpbind.client.requests.ignoreOveractivity **to the server properties to disable overactivity, but the server console only shows **xmpp.httpbind.client.requests.ignore **cropping Overactivity, but in database it shows the property ok.

As this is a sporadic error has anyoune dealt with this before? is this flag used to solve this problem?



Hi Joao!

I have been experimenting the same issue, I am using XIFF and it implements polling and a queue to handle the requests sent to the server. However reandomly the server returns a Policy Violation error. Did you get any improvements on this? I havent check on the server side, all I did was looking for a bug in my code, but so far I can’t find one.




it seems one main reason for the server to give this error is overactivity (to many requests in short period)

Try adding the following [property,value] in openfire admin console server properties:

(beware that, after adding, the openfire admin console will show only **xmpp.httpbind.client.requests.ignore **but in the database the value will be correct)

since i changed this flag i had no more occurrences of policy violation.

I only have sporadic #2032 errors now

best luck !


Wow, this was amazingly helpful, thanks!


Wowzers, I think I was hitting this too, interesting.