powered by Jive Software

SRV Record Problem

Hi there,

i run a openfire server with no srv records and it just work fine. Openfire runs at domain.tld - so there is no subdomain or smth. else. For now all services where subjected to registered user of my server However, today i just wanna set a srv record to open up muc chatrooms for people not using my jabber server. To do so i created a srv record _conference TCP 0 0 5222 domain.tld - should be right? The problem, even after 24 hours of waiting, nslookup tells me that there is no conference.domain.tld - tells me NXDOMAIN.

The question is as simple as this: why? Do i have to configure my openfire installtion somehow? Or what could be a possible reason?

Thanks in advance!

Hi rene,

my SRV record looks like (in bind format):

_xmpp-server._tcp.conference.domain.lt. SRV 10 10 5269 jabberserver.domain.lt.

and it works flawlessly. Maybe that helps.

Best regards

Just some more comments…

I’m not sure if nslookup can resolve SRV records, I use:

dig SRV _xmpp-server._tcp.conference.domain.lt

for checking SRV records.

You don’t need to configure Openfire for this, only you’re DNS. And the default port for server communication is 5269 instead of the c2s port 5222.

Hey,

nslookup can resolve srv records.

Your’re right with the port, it should be 5269! But that wasn’t the solution. I still can’t acces or browse through my muc-rooms from another server :frowning:

Maybe you can provide your DNS configuration that we can look on it and search the trouble.

I never touched my DNS configurations. I use two dns servers that my isp provides and they manage the whole thing. i can only add/delete a- mx- or srv-records for my domains.

Ok, if your server is jabber-server.de then it looks like:

dig SRV _xmpp-server._tcp.conference.jabber-server.de

; <<>> DiG 9.4.3-P2 <<>> SRV _xmpp-server._tcp.conference.jabber-server.de
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 52060
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;_xmpp-server._tcp.conference.jabber-server.de. IN SRV

;; AUTHORITY SECTION:
jabber-server.de. 2172 IN SOA ns1.hans.hosteurope.de. hostmaster.jabber-server.de. 2009072412 16384 2048 1048576 2560

;; Query time: 1 msec
;; SERVER: 141.89.48.3#53(141.89.48.3)
;; WHEN: Fri Jul 24 13:14:36 2009
;; MSG SIZE rcvd: 130

that means your DNS isn’t configured correctly. It should be something like:

dig SRV _xmpp-server._tcp.conference.cs.uni-potsdam.de

; <<>> DiG 9.4.3-P2 <<>> SRV _xmpp-server._tcp.conference.cs.uni-potsdam.de
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22549
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 6

;; QUESTION SECTION:
;_xmpp-server._tcp.conference.cs.uni-potsdam.de. IN SRV

;; ANSWER SECTION:
_xmpp-server._tcp.conference.cs.uni-potsdam.de. 43200 IN SRV 10 10 5269 lisa.cs.uni-potsdam.de.

;; AUTHORITY SECTION:
cs.uni-potsdam.de. 43200 IN NS radi.cs.uni-potsdam.de.
cs.uni-potsdam.de. 43200 IN NS nehemia.cs.uni-potsdam.de.
cs.uni-potsdam.de. 43200 IN NS schinkel.rz.uni-potsdam.de.
cs.uni-potsdam.de. 43200 IN NS ns.uni-potsdam.de.

;; ADDITIONAL SECTION:
lisa.cs.uni-potsdam.de. 43200 IN A 141.89.48.222
lisa.cs.uni-potsdam.de. 43200 IN AAAA 2001:638:807:30:218:f3ff:fe3a:3f55
ns.uni-potsdam.de. 2888 IN A 141.89.64.1
radi.cs.uni-potsdam.de. 43200 IN A 141.89.48.3
nehemia.cs.uni-potsdam.de. 43200 IN A 141.89.48.1
schinkel.rz.uni-potsdam.de. 2888 IN A 141.89.65.1

;; Query time: 3 msec
;; SERVER: 141.89.48.3#53(141.89.48.3)
;; WHEN: Fri Jul 24 13:12:47 2009
;; MSG SIZE rcvd: 298

So it’s no Openfire problem and you should ask your provider for help.