SSL Admin Console disabled

I am having a problem logging into the Admin Console via port 9091.

I did the initial setup and everything worked fine. Then I created and imported my own self-signed certificate.

Clients can connect fine once they accept the self-signed certificate. Admin console on port 9090 works perfectly. Admin console on port 9091 gives me the following error:

You tried to access the address https://brains:9091/, which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page.

Secure connection: fatal error (40) from server.

Failed to connect to server. The reason may be that the encryption methods supported by server are not enabled in the security preferences.


I have gone through the SSL guide and set all the server preferences up as described. SSL works fine on all the other web applications - although they are using a different (non-java) certificate. Netstat -l shows port 9091 is listening.

Using Wildfire 3.1.0 under linux with LDAP and MySQL.