SSL s2s Connections

I have been doing some research in the forums on this, but can’t really find a reason why this won’t work.

We have two independent installs of OpenFire and we are trying to do a s2s connection. Both servers have legitimate certificates. However when we implement require secure only connections, it will refuse to connect. I disable require secure only connections, it connects immediately.

Any thoughts on what I might be missing?

You can try some server-variables like:

xmpp.server.certificate.accept-selfsigned true

xmpp.server.certificate.verify false

xmpp.server.dialback.enabled true

Hey Greg,

Besides playing with the validation settings as mentioned above you may want to enable the debug log to see what is going on in each server.


– Gato