powered by Jive Software

SSO Not Working on Windows 7

I have followed all the steps in setting up SSO on the Openfire server and the workstation. SSO works great on all XP machines, and it works for most Windows 7 machines. However on some Windows 7 machines SSO will not work unless I right-click on the icon and select “Run as an administrator”. Even if I’m logged on as a Domain Administrator, I still have to launch the program with the “Run as an administrator” option. I also modified the Spark folder permission to allow the Everyone group full control to the folder, but I still have to do the same thing.

Whenever I try to run the program normally with the SSO option enabled, I get an error message saying “Unable to connect using Single Sign-On. Please check your principal and server settings.” I do not want to the user to manually launch the program everytime as I want it to automatically log the user in everytime they log into they’re computer.

I bet UAC is disabled on the the workstations that its working on, and enabled on the ones that its not.

Pretty much the UAC is the cause. That, and having local admin permissions (limited accounts work fine with UAC enabled).

If you don’t want to disable UAC, the only way to work around the issue is to create a task in the Task Scheduler with elevated permissions that launch Spark on login.

Yep, that was it. Thanks.

Once I disabled UAC it started working with no errors. Since I am installing this across the network I included the registry setting in ScriptLogic to modify every workstation’s registry with the following entry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\Ena bleLUA=0